summaryrefslogtreecommitdiffstats
path: root/main/hostapd
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-18 09:29:35 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-18 09:29:35 +0000
commitbd92489c71902e3b41c595e7aa5a765454d298b0 (patch)
tree08b6213f88c365e8229427064888ee9a5e62ccd1 /main/hostapd
parentc3a15effbf3fa6afb98382602b91db2327bf5adc (diff)
downloadaports-bd92489c71902e3b41c595e7aa5a765454d298b0.tar.bz2
aports-bd92489c71902e3b41c595e7aa5a765454d298b0.tar.xz
main/hostapd: fix musl build
Diffstat (limited to 'main/hostapd')
-rw-r--r--main/hostapd/APKBUILD15
-rw-r--r--main/hostapd/musl-fix-types.patch19
2 files changed, 32 insertions, 2 deletions
diff --git a/main/hostapd/APKBUILD b/main/hostapd/APKBUILD
index 83223a451..f7c204db6 100644
--- a/main/hostapd/APKBUILD
+++ b/main/hostapd/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hostapd
pkgver=2.0
-pkgrel=0
+pkgrel=1
pkgdesc="daemon for wireless software access points"
url="http://hostap.epitest.fi/hostapd/"
arch="all"
@@ -10,7 +10,7 @@ depends=
makedepends="openssl-dev libnl-dev"
install=
subpackages="$pkgname-doc"
-patches="CVE-2012-4445.patch"
+patches="CVE-2012-4445.patch musl-fix-types.patch"
source="http://hostap.epitest.fi/releases/$pkgname-$pkgver.tar.gz
$patches
$pkgname.initd
@@ -119,5 +119,16 @@ package() {
md5sums="ba22e639bc57aa4035d2ea8ffa9bbbee hostapd-2.0.tar.gz
0d01d4641e0c33f79c1f4372613655bf CVE-2012-4445.patch
+1ed73d28faae5d004bd8e34891df6eea musl-fix-types.patch
de734b22c3ad1e85309b5634d29c6225 hostapd.initd
c91382209042defa04e79d0ae841a29e hostapd.confd"
+sha256sums="262ce394b930bccc3d65fb99ee380f28d36444978f524c845a98e8e29f4e9d35 hostapd-2.0.tar.gz
+06dc7df2159fb0604191f66d35164caa5927963eebe77b5f2c389bd7590e2a49 CVE-2012-4445.patch
+35ec232335ccd8329d267bd75b972936e11cc4b487e47a1b73b390bb7551389e musl-fix-types.patch
+4bb2e7bfe8149353bb17ae74c3e6cf3c833af0b00303f7eb1eb4efe9867458e6 hostapd.initd
+6c14e88b14bb9a93d2dca69239d829f435e93180e621319aeed0f3987290dfba hostapd.confd"
+sha512sums="25fddaaddb22903078cfaae29a1e955b60955f9f5542b52962a6a8d4c65146ca102e9ac085118ce422843c55349a74a019220dfd4926895e301d506dbc97b967 hostapd-2.0.tar.gz
+619acce84516dead1e03e5da71657ea4c4b6f3ca8271574409773aeb316cbddc88095b50320804f457f001f4f3fe83053e660c008d8409f59bb4d3bfe058b601 CVE-2012-4445.patch
+9386de2aec75d5aa1da72c37a4fd0607d1666e9d3f0233a33a66a3ca4408cbb4efca1172a5b9b5d78dc88cf7ffab3366f38578a46f07d8aacc56c66b4a8e2cde musl-fix-types.patch
+d840249b8f537875948e192665b980884bfc977681e577b27e3c5ae4c9724b0c2123cfee72eebbd0d5a33bf0979d7837fc48f8053e66dd06854cca1e8689b798 hostapd.initd
+0882263bbd7c0b05bf51f51d66e11a23a0b8ca7da2a3b8a30166d2c5f044c0c134e6bccb1d02c9e81819ca8fb0c0fb55c7121a08fe7233ccaa73ff8ab9a238fe hostapd.confd"
diff --git a/main/hostapd/musl-fix-types.patch b/main/hostapd/musl-fix-types.patch
new file mode 100644
index 000000000..51625aeea
--- /dev/null
+++ b/main/hostapd/musl-fix-types.patch
@@ -0,0 +1,19 @@
+--- hostapd-2.0.orig/src/drivers/linux_wext.h
++++ hostapd-2.0/src/drivers/linux_wext.h
+@@ -21,11 +21,11 @@
+
+ #include <sys/types.h>
+ #include <net/if.h>
+-typedef __uint32_t __u32;
+-typedef __int32_t __s32;
+-typedef __uint16_t __u16;
+-typedef __int16_t __s16;
+-typedef __uint8_t __u8;
++typedef uint32_t __u32;
++typedef int32_t __s32;
++typedef uint16_t __u16;
++typedef int16_t __s16;
++typedef uint8_t __u8;
+ #ifndef __user
+ #define __user
+ #endif /* __user */