summaryrefslogtreecommitdiffstats
path: root/main/hylafax/APKBUILD
diff options
context:
space:
mode:
authorCameron Banta <cbanta@gmail.com>2010-10-27 19:53:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-28 12:29:30 +0000
commit3bcdfd488ace0b68eff4d1e9a9f4b9395fff28f0 (patch)
tree7e31466ea7f618d463bb817ab02c7438016f624b /main/hylafax/APKBUILD
parentc9e97cb90ef4f9bf2cfb78a01c9384a5d1a78608 (diff)
downloadaports-3bcdfd488ace0b68eff4d1e9a9f4b9395fff28f0.tar.bz2
aports-3bcdfd488ace0b68eff4d1e9a9f4b9395fff28f0.tar.xz
main/hylafax: update to 6.0.5 / patch for gcc4.5.1
Diffstat (limited to 'main/hylafax/APKBUILD')
-rw-r--r--main/hylafax/APKBUILD29
1 files changed, 20 insertions, 9 deletions
diff --git a/main/hylafax/APKBUILD b/main/hylafax/APKBUILD
index 419aebc91..5eadc15df 100644
--- a/main/hylafax/APKBUILD
+++ b/main/hylafax/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Cameron Banta <cbanta@gmail.com>
# Maintainer: Cameron Banta <cbanta@gmail.com>
pkgname=hylafax
-pkgver=4.4.4
-pkgrel=2
+pkgver=6.0.5
+pkgrel=0
pkgdesc="Sends and receives faxes"
url="http://www.hylafax.org/"
license="custom"
@@ -12,15 +12,20 @@ makedepends="zlib-dev tiff-dev"
install="hylafax.post-install"
subpackages="$pkgname-doc"
source="ftp://ftp.hylafax.org/source/$pkgname-$pkgver.tar.gz
+ gcc4.5.1.patch
+ $install
"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ patch -p1 < $startdir/gcc4.5.1.patch
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
- # Patch configure c++ problem
- sed -i -e 's:"iostream.h":<iostream>\n using namespace std;:g' \
- configure
-
# the configure script does not handle ccache or distcc
export CC=gcc
export CXX=g++
@@ -42,8 +47,12 @@ build() {
--with-PATH_EGETTY=/bin/false \
--with-PATH_VGETTY=/bin/false \
|| return 1
- make -j1 || return 1
+ make || return 1
+}
+package(){
+ cd "$_builddir"
+
# this makefile has issues installing, it doesn't use the standard
# install - but the following seems to work
mkdir -p "${pkgdir}"/usr/bin "${pkgdir}"/usr/sbin
@@ -77,4 +86,6 @@ build() {
# - which the user runs after install
}
-md5sums="4beb3d438ca6c4f00f1d94f9643e6668 hylafax-4.4.4.tar.gz"
+md5sums="eb9ac942354ad708e20e4583cec6615f hylafax-6.0.5.tar.gz
+bca78921c75448f63b451098528f5296 gcc4.5.1.patch
+a3553e6fc4de30e80759abe5c663c85b hylafax.post-install"