summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32/uclibc-resolv-tls.patch
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-05-26 23:09:04 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-05-26 23:09:04 +0000
commit9fddb4d5b41c0b5e69d5ee138297e95eff290302 (patch)
treeb353402b4af0ac5b912dc78ca7d996c397b8e2e3 /main/libc0.9.32/uclibc-resolv-tls.patch
parentccf26410d30adc8c1934dd553687157ed6e31d69 (diff)
parent8c1128e93e03012dabadb9a3f723dbd20eb60cd4 (diff)
downloadaports-9fddb4d5b41c0b5e69d5ee138297e95eff290302.tar.bz2
aports-9fddb4d5b41c0b5e69d5ee138297e95eff290302.tar.xz
Merged from Alpine main repository.
Merge Conflicts: main/abuild/APKBUILD main/cramfs/APKBUILD main/curl/APKBUILD main/dialog/APKBUILD main/libconfig/APKBUILD main/snort/APKBUILD main/syslinux/APKBUILD
Diffstat (limited to 'main/libc0.9.32/uclibc-resolv-tls.patch')
-rw-r--r--main/libc0.9.32/uclibc-resolv-tls.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/main/libc0.9.32/uclibc-resolv-tls.patch b/main/libc0.9.32/uclibc-resolv-tls.patch
new file mode 100644
index 000000000..45a228517
--- /dev/null
+++ b/main/libc0.9.32/uclibc-resolv-tls.patch
@@ -0,0 +1,15 @@
+diff --git a/libc/inet/resolv.c b/libc/inet/resolv.c
+index 320aec4..f8066d2 100644
+--- a/libc/inet/resolv.c
++++ b/libc/inet/resolv.c
+@@ -2916,8 +2916,8 @@ static void res_sync_func(void)
+ __nameserver[n].sa4 = rp->nsaddr_list[n]; /* struct copy */
+ #endif
+ }
+- __resolv_timeout = rp->retrans;
+- __resolv_attempts = rp->retry;
++ __resolv_timeout = rp->retrans ?: RES_TIMEOUT;
++ __resolv_attempts = rp->retry ?: RES_DFLRETRY;
+ /* Extend and comment what program is known
+ * to use which _res.XXX member(s).
+