summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-31 07:15:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-31 07:35:41 +0000
commitbf64cf5bfea50f6623fa653b4e8434047f186ee7 (patch)
treeed5ef9c3cbece6c93b396e19c1ef22999080f58a /main/libc0.9.32
parent5c6fbb4915033784f088b33ee73f361bb5103def (diff)
downloadaports-bf64cf5bfea50f6623fa653b4e8434047f186ee7.tar.bz2
aports-bf64cf5bfea50f6623fa653b4e8434047f186ee7.tar.xz
main/libc0.9.32: workaround for broken getprotobyname()
ref #412
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/getproto.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 9c89ef6a8..2acccb9a8 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -3,7 +3,7 @@ _abiver=0.9.32
pkgname=libc$_abiver
_gitver=1008060645
pkgver=${_abiver}_alpha0_git$_gitver
-pkgrel=2
+pkgrel=3
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -23,6 +23,7 @@ source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
0001-netdb-increase-line-size-for-etc-services.patch
0001-create-DEVEL_PREFIX-MULTILIB_DIR-dir-rather-than-DEV.patch
+ getproto.patch
uclibcconfig.x86
uclibcconfig.i486
"
@@ -110,5 +111,6 @@ d351ca4e5c33f4a7a60d4f1d754db5c4 0001-config-parser-fix-memory-corruption.patch
653b046611f98c990f1b52a28968ece3 0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
39ac96d750ad058030f917912bfea466 0001-netdb-increase-line-size-for-etc-services.patch
9dd8192227f54d6d3ccb49dc54137ff3 0001-create-DEVEL_PREFIX-MULTILIB_DIR-dir-rather-than-DEV.patch
+18afaad25c578bfbe1c7ddb0bea1228a getproto.patch
e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.x86
e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.i486"
diff --git a/main/libc0.9.32/getproto.patch b/main/libc0.9.32/getproto.patch
new file mode 100644
index 000000000..c58847443
--- /dev/null
+++ b/main/libc0.9.32/getproto.patch
@@ -0,0 +1,11 @@
+--- ./libc/inet/getproto.c.orig
++++ ./libc/inet/getproto.c
+@@ -28,7 +28,7 @@
+ __UCLIBC_MUTEX_STATIC(mylock, PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP);
+
+ #define MAXALIASES 35
+-#define BUFSZ (80) /* one line */
++#define BUFSZ (180) /* one line */
+ #define SBUFSIZE (BUFSZ + 1 + (sizeof(char *) * MAXALIASES))
+
+ static parser_t *protop = NULL;