summaryrefslogtreecommitdiffstats
path: root/main/libtirpc/libtirpc-no-des.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-30 06:16:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-30 06:16:45 +0000
commit315b80325847a20c0ce36d840075ae0a49a634b9 (patch)
treedaa97783a7be50a8ec57f0b7734ac3e92b487a93 /main/libtirpc/libtirpc-no-des.patch
parent311017b0174b8f42c08d2ab22ae05b16198c65ce (diff)
downloadaports-315b80325847a20c0ce36d840075ae0a49a634b9.tar.bz2
aports-315b80325847a20c0ce36d840075ae0a49a634b9.tar.xz
main/libtirpc: disable des encryption again
Diffstat (limited to 'main/libtirpc/libtirpc-no-des.patch')
-rw-r--r--main/libtirpc/libtirpc-no-des.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/main/libtirpc/libtirpc-no-des.patch b/main/libtirpc/libtirpc-no-des.patch
new file mode 100644
index 000000000..434726126
--- /dev/null
+++ b/main/libtirpc/libtirpc-no-des.patch
@@ -0,0 +1,29 @@
+--- libtirpc-0.2.5.orig/src/Makefile.am
++++ libtirpc-0.2.5/src/Makefile.am
+@@ -51,7 +51,7 @@
+ rpc_callmsg.c rpc_generic.c rpc_soc.c rpcb_clnt.c rpcb_prot.c \
+ rpcb_st_xdr.c svc.c svc_auth.c svc_dg.c svc_auth_unix.c svc_auth_none.c \
+ svc_generic.c svc_raw.c svc_run.c svc_simple.c svc_vc.c getpeereid.c \
+- auth_time.c auth_des.c authdes_prot.c debug.c
++ auth_time.c debug.c
+
+ ## XDR
+ libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c
+--- libtirpc-0.2.5.orig/src/rpc_soc.c
++++ libtirpc-0.2.5/src/rpc_soc.c
+@@ -520,6 +520,7 @@
+ (resultproc_t) rpc_wrap_bcast, "udp");
+ }
+
++#if 0
+ /*
+ * Create the client des authentication object. Obsoleted by
+ * authdes_seccreate().
+@@ -551,6 +552,7 @@
+ dummy = authdes_seccreate(servername, window, NULL, ckey);
+ return (dummy);
+ }
++#endif
+
+ /*
+ * Create a client handle for a unix connection. Obsoleted by clnt_vc_create()