summaryrefslogtreecommitdiffstats
path: root/main/lua-iconv/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-17 09:08:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-17 09:08:38 +0000
commit17d5c4cef95b78edb11a53ec40fa8ec52066fb2e (patch)
tree6c64cd3f18df37b232c2de72d754d76fd1929c24 /main/lua-iconv/APKBUILD
parent669e19155dc8d1649d48fa4a2ee8c972f2ff453d (diff)
downloadaports-17d5c4cef95b78edb11a53ec40fa8ec52066fb2e.tar.bz2
aports-17d5c4cef95b78edb11a53ec40fa8ec52066fb2e.tar.xz
main/lua-iconv: new aport
Diffstat (limited to 'main/lua-iconv/APKBUILD')
-rw-r--r--main/lua-iconv/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/lua-iconv/APKBUILD b/main/lua-iconv/APKBUILD
new file mode 100644
index 000000000..7f2f51718
--- /dev/null
+++ b/main/lua-iconv/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor:
+# Maintainer:
+pkgname=lua-iconv
+pkgver=6
+pkgrel=0
+pkgdesc="Lua binding to the POSIX 'iconv' library"
+url="http://luaforge.net/projects/lua-iconv/"
+license="MIT"
+depends=
+makedepends="libiconv-dev lua-dev"
+install=
+subpackages=
+source="http://luaforge.net/frs/download.php/4181/lua-iconv-6.tar.gz
+ 0001-lua-iconv-make-close-available-from-lua.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i "$srcdir"/0001-lua-iconv-make-close-available-from-lua.patch
+}
+
+build() {
+ cd "$_builddir"
+ make CFLAGS="$CFLAGS" LFLAGS="-llua -liconv -shared $LDFLAGS" \
+ || return 1
+}
+
+package() {
+ cd "$_builddir"
+ # tests fail
+ # make DESTDIR="$pkgdir" INSTALL_PATH=/usr/lib/lua/5.1 install
+ install -D -s iconv.so "$pkgdir"/usr/lib/lua/5.1/iconv.so
+}
+
+md5sums="2cec334c5786d7c420a53003d6cb93d4 lua-iconv-6.tar.gz
+88e23691e79f357a6048f226e8ed8e23 0001-lua-iconv-make-close-available-from-lua.patch"