summaryrefslogtreecommitdiffstats
path: root/main/menu-cache
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-22 17:32:36 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-22 17:32:36 +0200
commit20bf5ed84f79313f4238ddd01072ce5fd4c45736 (patch)
tree21317acdbdc83a6c750de7faa43f01f9b36b02ae /main/menu-cache
parent2be56e8d2878b588866c12b08b13dfc714ce52fd (diff)
downloadaports-20bf5ed84f79313f4238ddd01072ce5fd4c45736.tar.bz2
aports-20bf5ed84f79313f4238ddd01072ce5fd4c45736.tar.xz
testing/pcmanfm: move to main with dependencies
Diffstat (limited to 'main/menu-cache')
-rw-r--r--main/menu-cache/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/main/menu-cache/APKBUILD b/main/menu-cache/APKBUILD
new file mode 100644
index 000000000..db572b60a
--- /dev/null
+++ b/main/menu-cache/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=menu-cache
+pkgver=0.5.1
+pkgrel=1
+pkgdesc='Caching mechanism for freedesktop.org compliant menus'
+arch='all'
+license='GPL2'
+url='http://lxde.org/'
+makedepends='glib-dev'
+options='libtool'
+source="http://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-dev"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --libexecdir=/usr/lib/menu-cache \
+ --disable-static || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="fd296c317a235782fbbd37b6f54bc985 menu-cache-0.5.1.tar.gz"
+sha256sums="08e658021faecd4eefb26cc21b207251a6b4e844e131cec491471aba9eaea122 menu-cache-0.5.1.tar.gz"
+sha512sums="44d55a01f5452804e77518c4a2ba400a5b65edbf4061e346a6c02356195867eaa0bb9eaa057fbf603ddf79759acb16632bf3b7ae543eebc1544e28517cd23066 menu-cache-0.5.1.tar.gz"