summaryrefslogtreecommitdiffstats
path: root/main/ncmpc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-28 15:56:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-28 15:58:17 +0000
commit461fd51fe7bed1b38985213445aa236828554c5c (patch)
treee6cd01440e3243f01c4acc89b9002e68a3a2f91c /main/ncmpc
parent03ff3e56640277d5798314dbf79acc5bd7eff1e1 (diff)
downloadaports-461fd51fe7bed1b38985213445aa236828554c5c.tar.bz2
aports-461fd51fe7bed1b38985213445aa236828554c5c.tar.xz
main/ncmpc: move from testing and set maintainer
Diffstat (limited to 'main/ncmpc')
-rw-r--r--main/ncmpc/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/ncmpc/APKBUILD b/main/ncmpc/APKBUILD
new file mode 100644
index 000000000..28c175fb3
--- /dev/null
+++ b/main/ncmpc/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Maintainer: Peter Bui <pnutzh4x0r@gmail.com>
+pkgname=ncmpc
+pkgver=0.24
+pkgrel=0
+pkgdesc="Fully featured MPD client using ncurses"
+url="http://www.musicpd.org/clients/ncmpc/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev="ncurses-dev glib-dev libmpdclient-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://www.musicpd.org/download/${pkgname}/0/${pkgname}-${pkgver}.tar.xz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-lyrics-screen \
+ --with-lyrics-plugin-dir=/usr/share/ncmpc/lyrics \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ for i in lyrics/*; do
+ install -Dm755 "$i" "${pkgdir}/usr/share/ncmpc/$i" || return 1
+ done
+}
+
+md5sums="0717193f38446780372f2a8907316362 ncmpc-0.24.tar.xz"
+sha256sums="0e6f76b2b11449cfa479d2830ac681f4e3bff54a95a9134b069dd5a173b4c3e9 ncmpc-0.24.tar.xz"
+sha512sums="852bedec9d1e0f13748d00ded8a57b7824a3907fa4aef441cd016c13b3a4229e630957ee965d9f5cf7c1a0c47bfa3bb040058d32c6fcf6b4474acc57f834d929 ncmpc-0.24.tar.xz"