summaryrefslogtreecommitdiffstats
path: root/main/nspr/nspr-bb-shell.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-23 16:11:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-23 16:25:16 +0000
commit20bfd3c4af0191a19f976eb54f918bd8eb777a6c (patch)
treea30652dc055021151922ca3401483f7e187f8c25 /main/nspr/nspr-bb-shell.patch
parent303ae40e14e09b8f131910d7b323a01877639244 (diff)
downloadaports-20bfd3c4af0191a19f976eb54f918bd8eb777a6c.tar.bz2
aports-20bfd3c4af0191a19f976eb54f918bd8eb777a6c.tar.xz
main/nspr: fix the soname for libs
make sure that the soname patch gets used by running autoconf remove similar patch that does not work. again put the .so symlink to -dev package as it should not be needed anymore.
Diffstat (limited to 'main/nspr/nspr-bb-shell.patch')
-rw-r--r--main/nspr/nspr-bb-shell.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/main/nspr/nspr-bb-shell.patch b/main/nspr/nspr-bb-shell.patch
new file mode 100644
index 000000000..a336c2a56
--- /dev/null
+++ b/main/nspr/nspr-bb-shell.patch
@@ -0,0 +1,13 @@
+diff --git a/mozilla/nsprpub/configure.in b/mozilla/nsprpub/configure.in
+index 25dcca1..b508762 100644
+--- a/mozilla/nsprpub/configure.in
++++ b/mozilla/nsprpub/configure.in
+@@ -511,7 +511,7 @@ if test "$target" != "$host"; then
+
+ AC_MSG_CHECKING([whether the $host compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
+ AC_TRY_COMPILE([], [return(0);],
+- [ac_cv_prog_host_cc_works=1 AC_MSG_RESULT([yes])],
++ [ac_cv_prog_host_cc_works=1; AC_MSG_RESULT([yes])],
+ AC_MSG_ERROR([installation or configuration problem: $host compiler $HOST_CC cannot create executables.]) )
+
+ CC=$_SAVE_CC