summaryrefslogtreecommitdiffstats
path: root/main/open-vm-tools
diff options
context:
space:
mode:
authorJesse Young <jlyo@jlyo.org>2011-11-25 12:46:26 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-01 07:15:51 +0000
commitae1967b66eba132dd8c9fa5b5f57712d012b6647 (patch)
treefca1c166178cd340ea41b6d3794cf58c4152f2f4 /main/open-vm-tools
parent379338be8b4cd31b24080f7f01ae14fe124a84ae (diff)
downloadaports-ae1967b66eba132dd8c9fa5b5f57712d012b6647.tar.bz2
aports-ae1967b66eba132dd8c9fa5b5f57712d012b6647.tar.xz
Replace instances of "--chuid" to "--user" in initd scripts
Fixes #776 Signed-off-by: Jesse Young <jlyo@jlyo.org>
Diffstat (limited to 'main/open-vm-tools')
-rw-r--r--main/open-vm-tools/APKBUILD6
-rw-r--r--main/open-vm-tools/open-vm-tools.initd6
2 files changed, 6 insertions, 6 deletions
diff --git a/main/open-vm-tools/APKBUILD b/main/open-vm-tools/APKBUILD
index 6e31f2d0a..866c3d5d6 100644
--- a/main/open-vm-tools/APKBUILD
+++ b/main/open-vm-tools/APKBUILD
@@ -2,7 +2,7 @@
pkgname=open-vm-tools
pkgver=2011.09.23
_pkgsubver=491607
-pkgrel=1
+pkgrel=2
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="http://open-vm-tools.sourceforge.net/"
arch="all"
@@ -38,7 +38,7 @@ prepare() {
-e 's/__unused3/st_ctim.tv_nsec/g' \
lib/file/filePosix.c lib/hgfsServer/hgfsServerLinux.c \
|| return 1
-
+
# workaround automake-1.10 issue
# http://ramblingfoo.blogspot.com/2007/07/required-file-configrpath-not-found.html
touch config/config.rpath
@@ -87,5 +87,5 @@ md5sums="599342eee8d531b35ca1cc948b61868f open-vm-tools-2011.09.23-491607.tar.g
840e4d6ff3f53fc22bdedf4d64aabc91 ecvt.patch
89c7449323ddac4666b73a8467baf95a iconv-uclibc.patch
7d02fc25aba5c248f3d98dac238f175b libm.patch
-c96644aa42d611fae853a3a2095efc47 open-vm-tools.initd
+905ef6a3bac87c9ba2e5d3897ca230e7 open-vm-tools.initd
7b833102a56009bdfc2fef2fb9ffa297 procmgrposix.patch"
diff --git a/main/open-vm-tools/open-vm-tools.initd b/main/open-vm-tools/open-vm-tools.initd
index e54b84aaf..45a94a37e 100644
--- a/main/open-vm-tools/open-vm-tools.initd
+++ b/main/open-vm-tools/open-vm-tools.initd
@@ -39,15 +39,15 @@ start() {
mount -t vmblock none ${MOUNTPOINT}
eend $?
fi
-
+
ebegin "Starting vmtoolsd"
- start-stop-daemon --chuid "${USER_GROUP}" --start --quiet --background --make-pidfile --pidfile "${PIDFILE}" --exec ${GUESTD_BIN}
+ start-stop-daemon --user "${USER_GROUP}" --start --quiet --background --make-pidfile --pidfile "${PIDFILE}" --exec ${GUESTD_BIN}
eend $?
}
stop() {
local ret
-
+
if [ "${VM_DRAG_AND_DROP}" == "yes" ];
then
ebegin "Cleaning the contents of ${DND_TMPDIR}"