summaryrefslogtreecommitdiffstats
path: root/main/openssl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-08-07 08:35:12 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-08-07 08:35:12 +0300
commit7c34cd9c948a7bd20f05a136eaa9bec33c479849 (patch)
tree15a154a04adadb18e82c245273ec9088f103b71c /main/openssl
parentd4f5d980c75fd5b13a60637aafa549f1407a85c8 (diff)
downloadaports-7c34cd9c948a7bd20f05a136eaa9bec33c479849.tar.bz2
aports-7c34cd9c948a7bd20f05a136eaa9bec33c479849.tar.xz
main/openssl: fix man-pages properly
Failed to rebase the manpages patch properly. This removes the hunks that delete pages. Instead have the package script rename the affected man pages, and update the patch only to change the cross references of the conflicting man pages.
Diffstat (limited to 'main/openssl')
-rw-r--r--main/openssl/APKBUILD18
-rw-r--r--main/openssl/fix-manpages.patch126
2 files changed, 49 insertions, 95 deletions
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index 37d85e9ac..87da75d52 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=openssl
pkgver=1.0.1i
-pkgrel=1
+pkgrel=2
pkgdesc="Toolkit for SSL v2/v3 and TLS v1"
url="http://openssl.org"
depends=
@@ -98,9 +98,13 @@ package() {
cd "$_builddir"
make INSTALL_PREFIX="$pkgdir" MANDIR=/usr/share/man install || return 1
- # remove man pages that conflict with man-pages
- rm "$pkgdir"/usr/share/man/man3/rand.3 \
- "$pkgdir"/usr/share/man/man3/err.3
+ # rename man pages that conflict with man-pages
+ local m
+ for m in rand.3 err.3 threads.3 passwd.1; do
+ mv "$pkgdir"/usr/share/man/man${m/*.}/$m \
+ "$pkgdir"/usr/share/man/man${m/*.}/openssl-$m \
+ || return 1
+ done
}
libcrypto() {
@@ -125,7 +129,7 @@ libssl() {
}
md5sums="c8dc151a671b9b92ff3e4c118b174972 openssl-1.0.1i.tar.gz
-c5896bc17b3e95ba6329a3d6c2a6fd84 fix-manpages.patch
+f75151bfdd0e1f5191e0d0e7147e1638 fix-manpages.patch
c6a9857a5dbd30cead0404aa7dd73977 openssl-bb-basename.patch
ddb5fc155145d5b852425adaec32234d 0001-crypto-hmac-support-EVP_MD_CTX_FLAG_ONESHOT-and-set-.patch
4a7b9e20beb33a5e262ab64c2b8e5b48 0002-engines-e_padlock-backport-cvs-head-changes.patch
@@ -139,7 +143,7 @@ efec1bce615256961b1756e575ee1d0a fix-default-apps-capath.patch
60ca340e32944e4825747e3681ccd553 openssl-1.0.1-parallel-build.patch
b7f2421187ae2b4c7e424cda2022d41d abi-compat-no-freelists.patch"
sha256sums="3c179f46ca77069a6a0bac70212a9b3b838b2f66129cb52d568837fc79d8fcc7 openssl-1.0.1i.tar.gz
-99595db76e85785e265b69778e84f75f29a4e29945fb051f12fbb7c84667f453 fix-manpages.patch
+92296c9e121af10ecc1e302695bf2ceacaa9b00702e580504fc0ed04a9fba86e fix-manpages.patch
82863c2fed659a7186c7f3905a1853b8bd8060350ad101ce159fa7e7d2ba27e8 openssl-bb-basename.patch
18dd81fefb39b3328a444774ed10871ed50348ca171d2da9f826f916127b2dae 0001-crypto-hmac-support-EVP_MD_CTX_FLAG_ONESHOT-and-set-.patch
39c31c2e33cded09543a2d1fd2e3238e9d11c672ba71a14d13095baad3ec9696 0002-engines-e_padlock-backport-cvs-head-changes.patch
@@ -153,7 +157,7 @@ cbb2493ec9157e78035e9cc02be17655996ee9cd0a71b79507fc19f3862f452b 0003-engines-e
bd56e5fe1b6fe594ab93f34d25fef0b7372633bad8532f81da998f3e6655d221 openssl-1.0.1-parallel-build.patch
41c7c1e5bea7f7e0ccc59203a48f097948627d72fcf87f943fcfe8c14b4069a2 abi-compat-no-freelists.patch"
sha512sums="6cbcdcec8568236e8f20f0461f93df8a193a0ad88102ff548443e6ec87e2a7f649e314beee1e6bafda693934b4fb142244b61d14bf736828dda09e277b941d93 openssl-1.0.1i.tar.gz
-6d7770a63e721295d048641492e13fb09d292de1e9acd5e61ea0dd897e041d1627c7a7733ed2e5be86e26f0e8894edc123227808306b97cb6a2c6f5e941c9c33 fix-manpages.patch
+b0eda7e9b53195b0855da68617201c3c7026eb7464ab58f0bc9923013663ec6b826d1868fe88b87118d3134114cbd9ac15d2c8389c85ef9c1bb4d18575b68a5b fix-manpages.patch
6c4f4b0c1b606b3e5a8175618c4398923392f9c25ad8d3f5b65b0424fe51e104c4f456d2da590d9f572382225ab320278e88db1585790092450cad60a02819a5 openssl-bb-basename.patch
ea282b09d4692a29e5a554e19b0798fa921717d4892decc68cba92cad11e85e4064d8ac78d98f6fa8bb45c65fdd1a5d1a6f6755e53102d520e9d8b807c3a7822 0001-crypto-hmac-support-EVP_MD_CTX_FLAG_ONESHOT-and-set-.patch
96cdd28d1ad5efd3f5836b4c57c9c6ea8e790fbf919e32a8c4acd3883a3531b8d295053a4aa20e6165600153b141ce7b0a3d1d736fdfc325d59862b845aa4d98 0002-engines-e_padlock-backport-cvs-head-changes.patch
diff --git a/main/openssl/fix-manpages.patch b/main/openssl/fix-manpages.patch
index 857414842..082f8a578 100644
--- a/main/openssl/fix-manpages.patch
+++ b/main/openssl/fix-manpages.patch
@@ -55,94 +55,6 @@ index 738142e..e904f05 100644
L<pkcs12(1)|pkcs12(1)>, L<pkcs7(1)|pkcs7(1)>, L<pkcs8(1)|pkcs8(1)>,
L<rand(1)|rand(1)>, L<req(1)|req(1)>, L<rsa(1)|rsa(1)>,
L<rsautl(1)|rsautl(1)>, L<s_client(1)|s_client(1)>,
-diff --git a/doc/apps/passwd.pod b/doc/apps/passwd.pod
-deleted file mode 100644
-index f449825..0000000
---- a/doc/apps/passwd.pod
-+++ /dev/null
-@@ -1,82 +0,0 @@
--=pod
--
--=head1 NAME
--
--passwd - compute password hashes
--
--=head1 SYNOPSIS
--
--B<openssl passwd>
--[B<-crypt>]
--[B<-1>]
--[B<-apr1>]
--[B<-salt> I<string>]
--[B<-in> I<file>]
--[B<-stdin>]
--[B<-noverify>]
--[B<-quiet>]
--[B<-table>]
--{I<password>}
--
--=head1 DESCRIPTION
--
--The B<passwd> command computes the hash of a password typed at
--run-time or the hash of each password in a list. The password list is
--taken from the named file for option B<-in file>, from stdin for
--option B<-stdin>, or from the command line, or from the terminal otherwise.
--The Unix standard algorithm B<crypt> and the MD5-based BSD password
--algorithm B<1> and its Apache variant B<apr1> are available.
--
--=head1 OPTIONS
--
--=over 4
--
--=item B<-crypt>
--
--Use the B<crypt> algorithm (default).
--
--=item B<-1>
--
--Use the MD5 based BSD password algorithm B<1>.
--
--=item B<-apr1>
--
--Use the B<apr1> algorithm (Apache variant of the BSD algorithm).
--
--=item B<-salt> I<string>
--
--Use the specified salt.
--When reading a password from the terminal, this implies B<-noverify>.
--
--=item B<-in> I<file>
--
--Read passwords from I<file>.
--
--=item B<-stdin>
--
--Read passwords from B<stdin>.
--
--=item B<-noverify>
--
--Don't verify when reading a password from the terminal.
--
--=item B<-quiet>
--
--Don't output warnings when passwords given at the command line are truncated.
--
--=item B<-table>
--
--In the output list, prepend the cleartext password and a TAB character
--to each password hash.
--
--=back
--
--=head1 EXAMPLES
--
--B<openssl passwd -crypt -salt xx password> prints B<xxj31ZMTZzkVA>.
--
--B<openssl passwd -1 -salt xxxxxxxx password> prints B<$1$xxxxxxxx$UYCIxa628.9qXjpQCjM4a.>.
--
--B<openssl passwd -apr1 -salt xxxxxxxx password> prints B<$apr1$xxxxxxxx$dxHfLAsjHkDRmG83UXe8K0>.
--
--=cut
diff --git a/doc/crypto/BN_generate_prime.pod b/doc/crypto/BN_generate_prime.pod
index 7dccacb..71e7078 100644
--- a/doc/crypto/BN_generate_prime.pod
@@ -647,3 +559,41 @@ index f5ab1c3..63f7ebc 100644
+L<rsa(3)|rsa(3)>, L<dsa(3)|dsa(3)>, L<dh(3)|dh(3)>, L<openssl_rand(3)|openssl_rand(3)>
=cut
+diff --git a/doc/crypto/rsa.pod b/doc/crypto/rsa.pod
+index 45ac53f..5fa0dcc 100644
+--- a/doc/crypto/rsa.pod
++++ b/doc/crypto/rsa.pod
+@@ -108,7 +108,7 @@ RSA was covered by a US patent which expired in September 2000.
+ =head1 SEE ALSO
+
+ L<rsa(1)|rsa(1)>, L<bn(3)|bn(3)>, L<dsa(3)|dsa(3)>, L<dh(3)|dh(3)>,
+-L<rand(3)|rand(3)>, L<engine(3)|engine(3)>, L<RSA_new(3)|RSA_new(3)>,
++L<openssl_rand(3)|openssl_rand(3)>, L<engine(3)|engine(3)>, L<RSA_new(3)|RSA_new(3)>,
+ L<RSA_public_encrypt(3)|RSA_public_encrypt(3)>,
+ L<RSA_sign(3)|RSA_sign(3)>, L<RSA_size(3)|RSA_size(3)>,
+ L<RSA_generate_key(3)|RSA_generate_key(3)>,
+diff --git a/doc/ssl/SSL_get_error.pod b/doc/ssl/SSL_get_error.pod
+index 48c6b15..5432293 100644
+--- a/doc/ssl/SSL_get_error.pod
++++ b/doc/ssl/SSL_get_error.pod
+@@ -105,7 +105,7 @@ OpenSSL error queue contains more information on the error.
+
+ =head1 SEE ALSO
+
+-L<ssl(3)|ssl(3)>, L<err(3)|err(3)>
++L<ssl(3)|ssl(3)>, L<openssl_err(3)|openssl_err(3)>
+
+ =head1 HISTORY
+
+diff --git a/doc/ssl/SSL_want.pod b/doc/ssl/SSL_want.pod
+index c0059c0..2e51a75 100644
+--- a/doc/ssl/SSL_want.pod
++++ b/doc/ssl/SSL_want.pod
+@@ -72,6 +72,6 @@ return 1, when the corresponding condition is true or 0 otherwise.
+
+ =head1 SEE ALSO
+
+-L<ssl(3)|ssl(3)>, L<err(3)|err(3)>, L<SSL_get_error(3)|SSL_get_error(3)>
++L<ssl(3)|ssl(3)>, L<openssl_err(3)|openssl_err(3)>, L<SSL_get_error(3)|SSL_get_error(3)>
+
+ =cut