summaryrefslogtreecommitdiffstats
path: root/main/polkit/fix-parallel-make.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-04-15 13:56:24 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-04-15 13:56:24 +0300
commit0a7a893f64cb0bddefb5a7ca2593fd95bbf43e7b (patch)
tree6f417fe1ca8569e4dfdcdf27822468a68f0c3ee6 /main/polkit/fix-parallel-make.patch
parentbb62ff0be2acc91f2a2ed37e0314f0088684aef3 (diff)
downloadaports-0a7a893f64cb0bddefb5a7ca2593fd95bbf43e7b.tar.bz2
aports-0a7a893f64cb0bddefb5a7ca2593fd95bbf43e7b.tar.xz
main/polkit: fix parallel make, and update url
Diffstat (limited to 'main/polkit/fix-parallel-make.patch')
-rw-r--r--main/polkit/fix-parallel-make.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/polkit/fix-parallel-make.patch b/main/polkit/fix-parallel-make.patch
new file mode 100644
index 000000000..b693a34dd
--- /dev/null
+++ b/main/polkit/fix-parallel-make.patch
@@ -0,0 +1,40 @@
+From 7bd30764a5230684c7c979a08a83dfa6e327f719 Mon Sep 17 00:00:00 2001
+From: Ryan Lortie <desrt@velocity.(none)>
+Date: Tue, 13 Nov 2012 16:50:14 +0000
+Subject: build: Fix .gir generation for parallel make
+
+As per the intructions in the introspection Makefile, we should have a
+line declaring a dependency between the .gir and .la files.
+
+https://bugs.freedesktop.org/show_bug.cgi?id=57077
+
+Signed-off-by: David Zeuthen <zeuthen@gmail.com>
+---
+diff --git a/src/polkit/Makefile.am b/src/polkit/Makefile.am
+index 39d6d84..d648d29 100644
+--- a/src/polkit/Makefile.am
++++ b/src/polkit/Makefile.am
+@@ -106,6 +106,8 @@ if HAVE_INTROSPECTION
+
+ INTROSPECTION_GIRS = Polkit-1.0.gir
+
++Polkit-1.0.gir: libpolkit-gobject-1.la
++
+ girdir = $(INTROSPECTION_GIRDIR)
+ gir_DATA = Polkit-1.0.gir
+
+diff --git a/src/polkitagent/Makefile.am b/src/polkitagent/Makefile.am
+index 1cfb73c..5b7d4c7 100644
+--- a/src/polkitagent/Makefile.am
++++ b/src/polkitagent/Makefile.am
+@@ -108,6 +108,8 @@ if HAVE_INTROSPECTION
+ girdir = $(INTROSPECTION_GIRDIR)
+ gir_DATA = PolkitAgent-1.0.gir
+
++PolkitAgent-1.0.gir: libpolkit-agent-1.la
++
+ typelibsdir = $(INTROSPECTION_TYPELIBDIR)
+ typelibs_DATA = PolkitAgent-1.0.typelib
+
+--
+cgit v0.9.0.2-2-gbebe