summaryrefslogtreecommitdiffstats
path: root/main/rtorrent
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-30 06:50:11 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-30 06:50:11 +0000
commit3cbacc3c5e414a58ae215445519eb46db4921e08 (patch)
treefdda868b3483e251d6dd9c91f429ae094f093b45 /main/rtorrent
parentd48c529a8295229678d40751772417ef08a681f4 (diff)
downloadaports-3cbacc3c5e414a58ae215445519eb46db4921e08.tar.bz2
aports-3cbacc3c5e414a58ae215445519eb46db4921e08.tar.xz
main/[various]: update config.sub
Diffstat (limited to 'main/rtorrent')
-rw-r--r--main/rtorrent/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/rtorrent/APKBUILD b/main/rtorrent/APKBUILD
index 24399d2fc..9937e9d43 100644
--- a/main/rtorrent/APKBUILD
+++ b/main/rtorrent/APKBUILD
@@ -11,8 +11,15 @@ makedepends='libsigc++-dev libtorrent-dev curl-dev xmlrpc-c-dev ncurses-dev'
subpackages="$pkgname-doc"
source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
export LDFLAGS="$LDFLAGS -lpthread"
./configure \
@@ -27,7 +34,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
install -D doc/rtorrent.rc "$pkgdir"/usr/share/doc/rtorrent/rtorrent.r
}