summaryrefslogtreecommitdiffstats
path: root/main/rtorrent
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-07-30 08:51:11 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-07-30 08:54:53 +0000
commit5c904717322f8113870abf48cc93c3c8b00ab4e8 (patch)
treee077e5c3afa20630fd6e96db5872f03d622d639e /main/rtorrent
parenta879839450737e3cbdb64415af42347c97ccfa28 (diff)
downloadaports-5c904717322f8113870abf48cc93c3c8b00ab4e8.tar.bz2
aports-5c904717322f8113870abf48cc93c3c8b00ab4e8.tar.xz
[all autotools packages]: normalize ./configure
Diffstat (limited to 'main/rtorrent')
-rw-r--r--main/rtorrent/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/main/rtorrent/APKBUILD b/main/rtorrent/APKBUILD
index 0bd70d8da..24399d2fc 100644
--- a/main/rtorrent/APKBUILD
+++ b/main/rtorrent/APKBUILD
@@ -12,22 +12,24 @@ subpackages="$pkgname-doc"
source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$srcdir"/$pkgname-$pkgver
- export LDFLAGS="$LDFLAGS -lpthread"
- ./configure \
- --prefix=/usr \
- --disable-debug \
- --with-xmlrpc-c \
- || return 1
+ export LDFLAGS="$LDFLAGS -lpthread"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-debug \
+ --with-xmlrpc-c \
+ || return 1
- make || return 1
+ make || return 1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- install -D doc/rtorrent.rc "$pkgdir"/usr/share/doc/rtorrent/rtorrent.r
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -D doc/rtorrent.rc "$pkgdir"/usr/share/doc/rtorrent/rtorrent.r
}
md5sums="0bf2f262faa8c8c8d3b11ce286ea2bf2 rtorrent-0.9.3.tar.gz"