summaryrefslogtreecommitdiffstats
path: root/main/slim/no-slimlock.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-19 10:50:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-19 11:09:55 +0000
commit1aaf47d7aecbf7b029ce230e078f1e0c3cb31d88 (patch)
treeba0474eaab039565f2b0d373ae7fff69878d8eb6 /main/slim/no-slimlock.patch
parentdf0676cdcfb1ffaf0539717cc02223a57ebe25dc (diff)
downloadaports-1aaf47d7aecbf7b029ce230e078f1e0c3cb31d88.tar.bz2
aports-1aaf47d7aecbf7b029ce230e078f1e0c3cb31d88.tar.xz
main/slim: upgrade to 1.3.6 and enable consolekit support
Diffstat (limited to 'main/slim/no-slimlock.patch')
-rw-r--r--main/slim/no-slimlock.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/main/slim/no-slimlock.patch b/main/slim/no-slimlock.patch
new file mode 100644
index 000000000..1c728206e
--- /dev/null
+++ b/main/slim/no-slimlock.patch
@@ -0,0 +1,16 @@
+Fixes building without PAM
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9892c1d..eb1608b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -222,7 +222,9 @@ endif(BUILD_SLIMLOCK)
+ ####### install
+ # slim
+ install(TARGETS slim RUNTIME DESTINATION bin)
+-install(TARGETS slimlock RUNTIME DESTINATION bin)
++if(BUILD_SLIMLOCK)
++ install(TARGETS slimlock RUNTIME DESTINATION bin)
++endif(BUILD_SLIMLOCK)
+
+ if (BUILD_SHARED_LIBS)
+ set_target_properties(libslim PROPERTIES