summaryrefslogtreecommitdiffstats
path: root/main/snowfox
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-03-23 11:04:04 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-23 11:05:06 -0500
commitb6c26b417341af3b21955daafcb35197467b7e6a (patch)
tree885f91126a0b80e79597afd3b59bbc703909c553 /main/snowfox
parent601269c1a43a8f3859713bb1564a7e28c5f5dc0d (diff)
downloadaports-b6c26b417341af3b21955daafcb35197467b7e6a.tar.bz2
aports-b6c26b417341af3b21955daafcb35197467b7e6a.tar.xz
main/snowfox: new aport, firefox with patches
Diffstat (limited to 'main/snowfox')
-rw-r--r--main/snowfox/APKBUILD101
-rw-r--r--main/snowfox/firefox-agent.patch12
-rw-r--r--main/snowfox/firefox-defaults.patch22
-rw-r--r--main/snowfox/firefox-restore-fx3-tab-behaviour-as-default.patch11
-rw-r--r--main/snowfox/firefox-restore-status-bar.patch37
-rw-r--r--main/snowfox/firefox-version.patch11
-rw-r--r--main/snowfox/mozconfig36
7 files changed, 230 insertions, 0 deletions
diff --git a/main/snowfox/APKBUILD b/main/snowfox/APKBUILD
new file mode 100644
index 000000000..1041b25d0
--- /dev/null
+++ b/main/snowfox/APKBUILD
@@ -0,0 +1,101 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=snowfox
+pkgver=4.0
+_pkgver=4.0
+_xulver=2.0
+pkgrel=0
+pkgdesc="firefox web browser (unofficial branding; patched)"
+url="http://www.firefox.com"
+arch="all"
+license="GPL LGPL MPL"
+depends="xulrunner"
+makedepends="xulrunner-dev>=${_xulver}
+
+ nspr-dev
+ nss-dev
+ gtk+-dev
+ dbus-glib-dev
+ alsa-lib-dev
+ libvorbis-dev
+ libogg-dev
+ libtheora-dev
+ wireless-tools-dev
+ libnotify-dev
+ libevent-dev
+ libxt-dev
+ jpeg-dev
+ bzip2-dev
+ hunspell-dev
+ startup-notification-dev
+ sqlite-dev
+ libidl-dev
+
+ autoconf2.13
+
+ python
+ zip
+ yasm
+
+ autoconf
+ automake
+ libtool"
+install=""
+subpackages=""
+source="http://releases.mozilla.org/pub/mozilla.org/${pkgname}/releases/${pkgver}/source/${pkgname}-${_pkgver}.source.tar.bz2
+ mozconfig
+
+ firefox-restore-fx3-tab-behaviour-as-default.patch
+ firefox-restore-status-bar.patch
+ firefox-defaults.patch
+ firefox-version.patch
+
+ firefox.desktop
+ firefox-safe.desktop"
+
+_xulrunner_version="2.0"
+_builddir="${srcdir}/mozilla-${_xulrunner_version}"
+prepare() {
+ local i
+
+ cd "$_builddir"
+
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ cp "${srcdir}/mozconfig" .mozconfig
+}
+
+build() {
+ cd "$_builddir"
+
+ # mozilla's buildsystem is on drugs, so we just kill our CFLAGS and hope
+ # for the best. --nenolod
+ unset CFLAGS
+ unset CXXFLAGS
+
+ make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" -f client.mk install || return 1
+
+ install -m755 -d ${pkgdir}/usr/share/applications
+ install -m755 -d ${pkgdir}/usr/share/pixmaps
+ install -m644 ${srcdir}/mozilla-2.0/browser/branding/unofficial/default48.png ${pkgdir}/usr/share/pixmaps/firefox.png
+ install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/firefox.desktop
+ install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/firefox-safe.desktop
+}
+
+md5sums="3468a2c463b4fc2788ba621e4b511c30 firefox-4.0.source.tar.bz2
+d1ec45f9d953a868483094cce2b3eff5 mozconfig
+7cddbb1c76b9038ad1d85311dda81c95 firefox-restore-fx3-tab-behaviour-as-default.patch
+a153133cfe74ce269e1e80925e48544c firefox-restore-status-bar.patch
+475a0870730c88f48158a4d4ca9812d0 firefox-defaults.patch
+0e296aabf8c2b5fd5ef5b3a989bab03a firefox-version.patch
+ba96924ece1d77453e462429037a2ce5 firefox.desktop
+6f38a5899034b7786cb1f75ad42032b8 firefox-safe.desktop"
diff --git a/main/snowfox/firefox-agent.patch b/main/snowfox/firefox-agent.patch
new file mode 100644
index 000000000..299f327e2
--- /dev/null
+++ b/main/snowfox/firefox-agent.patch
@@ -0,0 +1,12 @@
+diff -Nur mozilla-1.9.2.orig/browser/app/profile/firefox.js mozilla-1.9.2/browser/app/profile/firefox.js
+--- mozilla-1.9.2.orig/browser/app/profile/firefox.js 2010-04-14 01:21:35.000000000 +0300
++++ mozilla-1.9.2/browser/app/profile/firefox.js 2010-04-21 00:16:59.673528609 +0300
+@@ -183,7 +183,7 @@
+
+ pref("general.useragent.locale", "@AB_CD@");
+ pref("general.skins.selectedSkin", "classic/1.0");
+-pref("general.useragent.extra.firefox", "@APP_UA_NAME@/@APP_VERSION@");
++pref("general.useragent.extra.firefox", "Firefox/@APP_VERSION@");
+
+ pref("general.smoothScroll", false);
+ #ifdef UNIX_BUT_NOT_MAC
diff --git a/main/snowfox/firefox-defaults.patch b/main/snowfox/firefox-defaults.patch
new file mode 100644
index 000000000..cce60cd5d
--- /dev/null
+++ b/main/snowfox/firefox-defaults.patch
@@ -0,0 +1,22 @@
+diff -Nur mozilla-1.9.2.old//browser/branding/unofficial/pref/firefox-branding.js mozilla-1.9.2/browser/branding/unofficial/pref/firefox-branding.js
+--- mozilla-1.9.2.old//browser/branding/unofficial/pref/firefox-branding.js 2010-04-14 01:21:35.000000000 +0300
++++ mozilla-1.9.2/browser/branding/unofficial/pref/firefox-branding.js 2010-04-20 23:55:01.290102941 +0300
+@@ -1,5 +1,5 @@
+-pref("startup.homepage_override_url","http://www.mozilla.org/projects/%APP%/%VERSION%/whatsnew/");
+-pref("startup.homepage_welcome_url","http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/");
++pref("startup.homepage_override_url","http://www.mozilla.com/%APP%/%VERSION%/whatsnew/");
++pref("startup.homepage_welcome_url","http://www.mozilla.com/%APP%/%VERSION%/firstrun/");
+ pref("browser.panorama.welcome_url", "http://www.mozilla.com/firefox/panorama/");
+ // The time interval between checks for a new version (in seconds)
+ // nightly=8 hours, official=24 hours
+@@ -14,7 +14,7 @@
+ pref("app.update.url.details", "http://www.mozilla.org/projects/%APP%/");
+
+ // Release notes and vendor URLs
+-pref("app.releaseNotesURL", "http://www.mozilla.org/projects/%APP%/%VERSION%/releasenotes/");
+-pref("app.vendorURL", "http://www.mozilla.org/projects/%APP%/");
++pref("app.releaseNotesURL", "http://www.mozilla.com/%APP%/%VERSION%/releasenotes/");
++pref("app.vendorURL", "http://www.mozilla.com/%APP%/");
+
+ // Search codes belong only in builds with official branding
+ pref("browser.search.param.yahoo-fr", "");
diff --git a/main/snowfox/firefox-restore-fx3-tab-behaviour-as-default.patch b/main/snowfox/firefox-restore-fx3-tab-behaviour-as-default.patch
new file mode 100644
index 000000000..a9102a65b
--- /dev/null
+++ b/main/snowfox/firefox-restore-fx3-tab-behaviour-as-default.patch
@@ -0,0 +1,11 @@
+--- mozilla-2.0.orig/browser/base/content/browser.xul
++++ mozilla-2.0/browser/base/content/browser.xul
+@@ -470,7 +470,7 @@
+ #else
+ iconsize="large"
+ #endif
+- tabsontop="true"
++ tabsontop="false"
+ persist="tabsontop">
+ <!-- Menu -->
+ <toolbar type="menubar" id="toolbar-menubar" class="chromeclass-menubar" customizable="true"
diff --git a/main/snowfox/firefox-restore-status-bar.patch b/main/snowfox/firefox-restore-status-bar.patch
new file mode 100644
index 000000000..f492abb59
--- /dev/null
+++ b/main/snowfox/firefox-restore-status-bar.patch
@@ -0,0 +1,37 @@
+--- mozilla-2.0.orig/browser/base/content/browser.xul
++++ mozilla-2.0/browser/base/content/browser.xul
+@@ -992,12 +992,18 @@
+ contentcontextmenu="contentAreaContextMenu"
+ autocompletepopup="PopupAutoComplete"
+ onclick="return contentAreaClick(event, false);"/>
+- <statuspanel id="statusbar-display" label=""/>
+ </vbox>
+ <vbox id="browser-border-end" hidden="true" layer="true"/>
+ </hbox>
+
+ <vbox id="browser-bottombox" layer="true">
++ <statusbar id="status-bar" ordinal="1000"
++#ifdef WINCE
++ hidden="true"
++#endif
++ class="chromeclass-status">
++ <statusbarpanel id="statusbar-display" label=""/>
++ </statusbar>
+ <toolbar id="addon-bar"
+ toolbarname="&addonBarCmd.label;" accesskey="&addonBarCmd.accesskey;"
+ collapsed="true"
+@@ -1005,13 +1011,12 @@
+ context="toolbar-context-menu" toolboxid="navigator-toolbox"
+ mode="icons" iconsize="small" defaulticonsize="small"
+ lockiconsize="true"
+- defaultset="addonbar-closebutton,spring,status-bar"
++ defaultset="addonbar-closebutton,spring"
+ customizable="true"
+ key="key_toggleAddonBar">
+ <toolbarbutton id="addonbar-closebutton"
+ tooltiptext="&addonBarCloseButton.tooltip;"
+ oncommand="setToolbarVisibility(this.parentNode, false);"/>
+- <statusbar id="status-bar" ordinal="1000"/>
+ </toolbar>
+ </vbox>
+
diff --git a/main/snowfox/firefox-version.patch b/main/snowfox/firefox-version.patch
new file mode 100644
index 000000000..2b1aeb41d
--- /dev/null
+++ b/main/snowfox/firefox-version.patch
@@ -0,0 +1,11 @@
+--- mozilla-2.0.orig/browser/installer/Makefile.in 2009-07-18 13:32:35.000000000 +0200
++++ mozilla-2.0/browser/installer/Makefile.in 2009-07-18 13:33:12.000000000 +0200
+@@ -43,6 +43,8 @@
+
+ include $(DEPTH)/config/autoconf.mk
+
++MOZ_APP_VERSION="3.6"
++
+ include $(topsrcdir)/config/rules.mk
+
+ MOZ_PKG_REMOVALS = $(srcdir)/removed-files.in
diff --git a/main/snowfox/mozconfig b/main/snowfox/mozconfig
new file mode 100644
index 000000000..e68be73fa
--- /dev/null
+++ b/main/snowfox/mozconfig
@@ -0,0 +1,36 @@
+. $topsrcdir/browser/config/mozconfig
+
+ac_add_options --prefix=/usr
+ac_add_options --libdir=/usr/lib
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-pthreads
+ac_add_options --disable-tests
+ac_add_options --disable-debug
+ac_add_options --enable-optimize
+ac_add_options --disable-installer
+ac_add_options --enable-xinerama
+ac_add_options --enable-default-toolkit=cairo-gtk2
+ac_add_options --disable-xprint
+ac_add_options --enable-strip
+ac_add_options --enable-pango
+ac_add_options --enable-svg
+ac_add_options --enable-canvas
+ac_add_options --enable-startup-notification
+ac_add_options --enable-libxul
+ac_add_options --disable-crashreporter
+ac_add_options --disable-updater
+ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-1.9.2
+ac_add_options --enable-safe-browsing
+ac_add_options --with-branding=browser/branding/unofficial
+ac_add_options --enable-chrome-format=jar
+
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export USE_SHORT_LIBNAME=1
+
+mk_add_options BUILD_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
+mk_add_options USE_SHORT_LIBNAME=1