summaryrefslogtreecommitdiffstats
path: root/main/syslinux/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-03 16:49:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-03 19:28:23 +0000
commitb0740647731bf96a401540e02ce54753da77057f (patch)
treeba378968f65997bdf0141fee861edf9006e8f206 /main/syslinux/APKBUILD
parentc504465e61a866c92c41e38ccc888d58abc73d09 (diff)
downloadaports-b0740647731bf96a401540e02ce54753da77057f.tar.bz2
aports-b0740647731bf96a401540e02ce54753da77057f.tar.xz
main/syslinux: misc update-extlinux fixes
- rename /etc/extlinux-conf to /etc/update-extlinux.conf - Do not exit with fail if update-extlinux.conf is missing - Always warn if root= is not defined in update-extlinux.conf - Try harder to detect the root device by parsing /proc/mounts - Exit with error if we cannot detect the Root device - Rename fancy_menu to vesa_menu - Unifiy the code generating vesa/standard menus - Keep a backup of old extlinux.conf - add "overwrite" config option so it is possible to skip overwriting the extlinux.conf. - Added a post-upgrade that imports current extlinux.conf to update-extlinux.conf
Diffstat (limited to 'main/syslinux/APKBUILD')
-rw-r--r--main/syslinux/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/main/syslinux/APKBUILD b/main/syslinux/APKBUILD
index 5a962cfdd..6687475c5 100644
--- a/main/syslinux/APKBUILD
+++ b/main/syslinux/APKBUILD
@@ -1,16 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=syslinux
pkgver=4.04
-pkgrel=4
-pkgdesc="a boot loader for the Linux operating system which operates off an MS-DOS/Windows FAT filesystem."
+pkgrel=5
+pkgdesc="Boot loader for the Linux operating system"
url="http://syslinux.org"
arch="x86 x86_64"
license="GPL"
makedepends="nasm perl"
depends="mtools blkid"
-triggers=""
+triggers="syslinux.trigger=/boot"
+install="syslinux.post-upgrade"
source="http://www.kernel.org/pub/linux/utils/boot/syslinux/${pkgver%%.*}.xx/$pkgname-$pkgver.tar.bz2
- extlinux.conf
+ update-extlinux.conf
update-extlinux
"
subpackages="$pkgname-doc"
@@ -30,11 +31,11 @@ package() {
cd "$_builddir"
make INSTALLROOT="$pkgdir" MANDIR=/usr/share/man local-install
- mkdir -p "$pkgdir"/etc
- cp "$srcdir"/extlinux.conf "$pkgdir"/etc/
+ mkdir -p "$pkgdir"/etc/update-extlinux.d
+ cp "$srcdir"/update-extlinux.conf "$pkgdir"/etc/
cp "$srcdir"/update-extlinux "$pkgdir"/sbin/
}
md5sums="a3936208767eb7ced65320abe2e33a10 syslinux-4.04.tar.bz2
-37f8ae1cbb41b68241d6027abd828318 extlinux.conf
-0d769b8a7c01137535bbd26f130a0658 update-extlinux"
+14443fe391bd315a54478851abdc32cb update-extlinux.conf
+7164c110dae13a8d06d175943e48b841 update-extlinux"