summaryrefslogtreecommitdiffstats
path: root/main/tevent
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-16 18:05:15 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-16 18:05:15 +0000
commit154d0de0751c7e77ae7099454b4a2693ad7f505d (patch)
tree258c356869d7298357b1273efb1e301016746fb6 /main/tevent
parent9ac23e7a814da2123d5f362d2ddcd7938cf722cb (diff)
downloadaports-154d0de0751c7e77ae7099454b4a2693ad7f505d.tar.bz2
aports-154d0de0751c7e77ae7099454b4a2693ad7f505d.tar.xz
main/tevent: fix musl build
Diffstat (limited to 'main/tevent')
-rw-r--r--main/tevent/APKBUILD14
-rw-r--r--main/tevent/fix-libreplace.patch84
2 files changed, 93 insertions, 5 deletions
diff --git a/main/tevent/APKBUILD b/main/tevent/APKBUILD
index 3fbcf3b8c..7c0e9ad49 100644
--- a/main/tevent/APKBUILD
+++ b/main/tevent/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tevent
pkgver=0.9.19
-pkgrel=1
+pkgrel=2
pkgdesc="The tevent library"
url="http://tevent.samba.org/"
arch="all"
@@ -12,7 +12,8 @@ makedepends="$depends_dev python-dev talloc-dev"
replaces="samba"
install=""
subpackages="$pkgname-dev py-$pkgname:_py"
-source="http://samba.org/ftp/tevent/tevent-$pkgver.tar.gz"
+source="http://samba.org/ftp/tevent/tevent-$pkgver.tar.gz
+ fix-libreplace.patch"
_builddir="$srcdir"/tevent-$pkgver
prepare() {
@@ -53,6 +54,9 @@ _py() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-md5sums="f9ecb7e344bd20fb40f05e97116523f2 tevent-0.9.19.tar.gz"
-sha256sums="f9a1d079844ec0068804541ee2421d8ff34d7a4cdb93a6cc20d0edd5302e3fc9 tevent-0.9.19.tar.gz"
-sha512sums="9c8eb11dc8efbf6b7651261bb4359c6100022145df749630c116ecafea62f6527c3cc7ab73499e3ff1854454aab3947c58d49a9765fc857ac0ddd90250299d0d tevent-0.9.19.tar.gz"
+md5sums="f9ecb7e344bd20fb40f05e97116523f2 tevent-0.9.19.tar.gz
+b8c06c1a37bce8a7feea3b6896483da0 fix-libreplace.patch"
+sha256sums="f9a1d079844ec0068804541ee2421d8ff34d7a4cdb93a6cc20d0edd5302e3fc9 tevent-0.9.19.tar.gz
+13617f691c648b44867c1a76d8be7c185021e8a8f3b695f8689a9f6244e65827 fix-libreplace.patch"
+sha512sums="9c8eb11dc8efbf6b7651261bb4359c6100022145df749630c116ecafea62f6527c3cc7ab73499e3ff1854454aab3947c58d49a9765fc857ac0ddd90250299d0d tevent-0.9.19.tar.gz
+4adbbeb75de6c55199e10f284e741ee252f403b7809251caf4baf378669770be01d469b23e12f8119ed5dca5080dd45bda1b5b78cc7a791be44c1eb6fb8c0fa2 fix-libreplace.patch"
diff --git a/main/tevent/fix-libreplace.patch b/main/tevent/fix-libreplace.patch
new file mode 100644
index 000000000..cfe24757e
--- /dev/null
+++ b/main/tevent/fix-libreplace.patch
@@ -0,0 +1,84 @@
+--- talloc-2.1.0.orig/lib/replace/replace.c
++++ talloc-2.1.0/lib/replace/replace.c
+@@ -508,28 +508,6 @@
+ # error "You need a strtoll function"
+ #endif
+ }
+-#else
+-#ifdef HAVE_BSD_STRTOLL
+-#ifdef HAVE_STRTOQ
+-long long int rep_strtoll(const char *str, char **endptr, int base)
+-{
+- long long int nb = strtoq(str, endptr, base);
+- /* In linux EINVAL is only returned if base is not ok */
+- if (errno == EINVAL) {
+- if (base == 0 || (base >1 && base <37)) {
+- /* Base was ok so it's because we were not
+- * able to make the convertion.
+- * Let's reset errno.
+- */
+- errno = 0;
+- }
+- }
+- return nb;
+-}
+-#else
+-#error "You need the strtoq function"
+-#endif /* HAVE_STRTOQ */
+-#endif /* HAVE_BSD_STRTOLL */
+ #endif /* HAVE_STRTOLL */
+
+
+@@ -546,28 +524,6 @@
+ # error "You need a strtoull function"
+ #endif
+ }
+-#else
+-#ifdef HAVE_BSD_STRTOLL
+-#ifdef HAVE_STRTOUQ
+-unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
+-{
+- unsigned long long int nb = strtouq(str, endptr, base);
+- /* In linux EINVAL is only returned if base is not ok */
+- if (errno == EINVAL) {
+- if (base == 0 || (base >1 && base <37)) {
+- /* Base was ok so it's because we were not
+- * able to make the convertion.
+- * Let's reset errno.
+- */
+- errno = 0;
+- }
+- }
+- return nb;
+-}
+-#else
+-#error "You need the strtouq function"
+-#endif /* HAVE_STRTOUQ */
+-#endif /* HAVE_BSD_STRTOLL */
+ #endif /* HAVE_STRTOULL */
+
+ #ifndef HAVE_SETENV
+--- talloc-2.1.0.orig/lib/replace/replace.h
++++ talloc-2.1.0/lib/replace/replace.h
+@@ -355,21 +355,11 @@
+ #ifndef HAVE_STRTOLL
+ #define strtoll rep_strtoll
+ long long int rep_strtoll(const char *str, char **endptr, int base);
+-#else
+-#ifdef HAVE_BSD_STRTOLL
+-#define strtoll rep_strtoll
+-long long int rep_strtoll(const char *str, char **endptr, int base);
+ #endif
+-#endif
+
+ #ifndef HAVE_STRTOULL
+ #define strtoull rep_strtoull
+ unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
+-#else
+-#ifdef HAVE_BSD_STRTOLL /* yes, it's not HAVE_BSD_STRTOULL */
+-#define strtoull rep_strtoull
+-unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
+-#endif
+ #endif
+
+ #ifndef HAVE_FTRUNCATE