summaryrefslogtreecommitdiffstats
path: root/main/tevent
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-28 14:32:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-28 15:28:47 +0000
commit9f3723260fa221450e72240eb01794f58bd9f6b0 (patch)
tree83c19921d0f87387c41b4d70cdd4441268015e69 /main/tevent
parentcf6c7b76cc8ad4f4a0fe7da578a0d6a233b3b974 (diff)
downloadaports-9f3723260fa221450e72240eb01794f58bd9f6b0.tar.bz2
aports-9f3723260fa221450e72240eb01794f58bd9f6b0.tar.xz
main/tevent: moved from testing
Diffstat (limited to 'main/tevent')
-rw-r--r--main/tevent/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/main/tevent/APKBUILD b/main/tevent/APKBUILD
new file mode 100644
index 000000000..be732d1a4
--- /dev/null
+++ b/main/tevent/APKBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=tevent
+pkgver=0.9.19
+pkgrel=0
+pkgdesc="The tevent library"
+url="http://tevent.samba.org/"
+arch="all"
+license="LGPLv3+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev python-dev talloc-dev"
+replaces="samba"
+install=""
+subpackages="$pkgname-dev py-$pkgname:_py"
+source="http://samba.org/ftp/tevent/tevent-$pkgver.tar.gz"
+
+_builddir="$srcdir"/tevent-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-rpath \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+_py() {
+ pkgdesc="Python binding for the tevent library"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+md5sums="f9ecb7e344bd20fb40f05e97116523f2 tevent-0.9.19.tar.gz"
+sha256sums="f9a1d079844ec0068804541ee2421d8ff34d7a4cdb93a6cc20d0edd5302e3fc9 tevent-0.9.19.tar.gz"
+sha512sums="9c8eb11dc8efbf6b7651261bb4359c6100022145df749630c116ecafea62f6527c3cc7ab73499e3ff1854454aab3947c58d49a9765fc857ac0ddd90250299d0d tevent-0.9.19.tar.gz"