summaryrefslogtreecommitdiffstats
path: root/main/tiff/tiff-jpegfix.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-23 09:37:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-23 09:42:24 +0000
commit4fae22ebc20517a01951fbc52d14eab131e66c5b (patch)
tree74643da93076f2145aa77060a3abf8d807ed9973 /main/tiff/tiff-jpegfix.patch
parent6c830b0725e1936ca196495fcd1dfd89c91fb769 (diff)
downloadaports-4fae22ebc20517a01951fbc52d14eab131e66c5b.tar.bz2
aports-4fae22ebc20517a01951fbc52d14eab131e66c5b.tar.xz
main/tiff: upgrade to 3.9.5
and clean up the APKBUILD
Diffstat (limited to 'main/tiff/tiff-jpegfix.patch')
-rw-r--r--main/tiff/tiff-jpegfix.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/main/tiff/tiff-jpegfix.patch b/main/tiff/tiff-jpegfix.patch
deleted file mode 100644
index ca57191df..000000000
--- a/main/tiff/tiff-jpegfix.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -Nru tiff-3.9.2.orig/libtiff/tif_jpeg.c tiff-3.9.2/libtiff/tif_jpeg.c
---- tiff-3.9.2.orig/libtiff/tif_jpeg.c 2009-12-22 12:45:49.969811264 -0800
-+++ tiff-3.9.2/libtiff/tif_jpeg.c 2009-12-22 12:47:04.433491064 -0800
-@@ -2014,7 +2014,14 @@
- if( tif->tif_diroff == 0 )
- {
- #define SIZE_OF_JPEGTABLES 2000
-+/*
-+The following line assumes incorrectly that all JPEG-in-TIFF files will have
-+a JPEGTABLES tag generated and causes null-filled JPEGTABLES tags to be written
-+when the JPEG data is placed with TIFFWriteRawStrip. The field bit should be
-+set, anyway, later when actual JPEGTABLES header is generated, so removing it
-+here hopefully is harmless.
- TIFFSetFieldBit(tif, FIELD_JPEGTABLES);
-+*/
- sp->jpegtables_length = SIZE_OF_JPEGTABLES;
- sp->jpegtables = (void *) _TIFFmalloc(sp->jpegtables_length);
- _TIFFmemset(sp->jpegtables, 0, SIZE_OF_JPEGTABLES);
-diff -Nru tiff-3.9.2.orig/tools/tiff2pdf.c tiff-3.9.2/tools/tiff2pdf.c
---- tiff-3.9.2.orig/tools/tiff2pdf.c 2009-12-22 12:45:49.873825856 -0800
-+++ tiff-3.9.2/tools/tiff2pdf.c 2009-12-22 12:48:16.558526392 -0800
-@@ -3320,6 +3320,9 @@
- while(i<(*striplength)){
- switch( strip[i] ){
- case 0xd8:
-+ /* SOI - start of image */
-+ _TIFFmemcpy(&(buffer[*bufferoffset]), &(strip[i-1]), 2);
-+ *bufferoffset+=2;
- i+=2;
- break;
- case 0xc0: