summaryrefslogtreecommitdiffstats
path: root/main/wine
diff options
context:
space:
mode:
authorAustin English <austinenglish@gmail.com>2011-09-12 04:54:56 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2011-09-12 18:29:44 +0000
commitfd49c5d0180f075438a3ad75918138b68f683741 (patch)
tree025bcf11eef1e5153a28770df0cecd84906dd9c4 /main/wine
parent12e26357420274c24b55fc456ed8f64d213b8dbc (diff)
downloadaports-fd49c5d0180f075438a3ad75918138b68f683741.tar.bz2
aports-fd49c5d0180f075438a3ad75918138b68f683741.tar.xz
wine: update to 1.3.28
Diffstat (limited to 'main/wine')
-rw-r--r--main/wine/APKBUILD13
-rw-r--r--main/wine/dn_skipname.patch38
-rw-r--r--main/wine/uclibc-fmaxf-fminf.patch21
3 files changed, 4 insertions, 68 deletions
diff --git a/main/wine/APKBUILD b/main/wine/APKBUILD
index 6b31e8e74..7b4dbfdf6 100644
--- a/main/wine/APKBUILD
+++ b/main/wine/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wine
-pkgver=1.3.27
+pkgver=1.3.28
pkgrel=0
pkgdesc="A compatibility layer for running Windows programs"
url="http://www.winehq.com"
@@ -11,12 +11,10 @@ makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison
libpng-dev jpeg-dev freetype-dev ncurses-dev openssl-dev
libxcomposite-dev libxrender-dev libxinerama-dev zlib-dev
- fontconfig-dev cups-dev alsa-lib-dev lcms-dev libxml2-dev
+ cups-dev alsa-lib-dev lcms-dev libxml2-dev
gstreamer-dev gst-plugins-base-dev paxctl
autoconf automake"
source="http://ibiblio.org/pub/linux/system/emulators/$pkgname/$pkgname-$pkgver.tar.bz2
- dn_skipname.patch
- uclibc-fmaxf-fminf.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -36,9 +34,8 @@ prepare() {
build() {
cd "$_builddir"
./configure --prefix=/usr \
- --sysconfdir=/etc/wine \
--with-x
- make depend && make
+ make
}
package() {
@@ -49,6 +46,4 @@ package() {
"$pkgdir"/usr/bin/wine
}
-md5sums="d717ecec6959d8cab194c61c29c3dcdf wine-1.3.27.tar.bz2
-6ebeaa64eddf97be3267db236ce84b71 dn_skipname.patch
-1127b41caf4de8f567b9a3d0aff5277f uclibc-fmaxf-fminf.patch"
+md5sums="d717ecec6959d8cab194c61c29c3dcdf wine-1.3.27.tar.bz2"
diff --git a/main/wine/dn_skipname.patch b/main/wine/dn_skipname.patch
deleted file mode 100644
index 99ecf8315..000000000
--- a/main/wine/dn_skipname.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- ./dlls/dnsapi/ns_parse.c.orig
-+++ ./dlls/dnsapi/ns_parse.c
-@@ -69,6 +69,35 @@
- } while (0)
-
- /* Public. */
-+#ifdef __UCLIBC__
-+int
-+dn_skipname(const u_char *comp_dn, const u_char *eom)
-+{
-+ const u_char *cp;
-+ int n;
-+
-+ cp = comp_dn;
-+ while (cp < eom && (n = *cp++)) {
-+ /*
-+ * check for indirection
-+ */
-+ switch (n & INDIR_MASK) {
-+ case 0: /* normal case, n == len */
-+ cp += n;
-+ continue;
-+ case INDIR_MASK: /* indirection */
-+ cp++;
-+ break;
-+ default: /* illegal type */
-+ return (-1);
-+ }
-+ break;
-+ }
-+ if (cp > eom)
-+ return (-1);
-+ return (cp - comp_dn);
-+}
-+#endif
-
- static int
- dns_ns_skiprr(const u_char *ptr, const u_char *eom, ns_sect section, int count) {
diff --git a/main/wine/uclibc-fmaxf-fminf.patch b/main/wine/uclibc-fmaxf-fminf.patch
deleted file mode 100644
index 1f26cb8b9..000000000
--- a/main/wine/uclibc-fmaxf-fminf.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./dlls/d3dx9_36/mesh.c.orig
-+++ ./dlls/d3dx9_36/mesh.c
-@@ -40,6 +40,18 @@
- #include "wine/list.h"
- #include "d3dx9_36_private.h"
-
-+#ifdef __UCLIBC__
-+float fmaxf(float a, float b)
-+{
-+ return (a > b) ? a : b;
-+}
-+
-+float fminf(float a, float b)
-+{
-+ return (a < b) ? a : b;
-+}
-+#endif
-+
- WINE_DEFAULT_DEBUG_CHANNEL(d3dx);
-
- typedef struct ID3DXMeshImpl