summaryrefslogtreecommitdiffstats
path: root/main/x264
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-17 11:18:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-17 11:19:13 +0000
commita4bde33c11ae0e960f722f6e6904eedd42f3c532 (patch)
tree007f3ba96b9d20f09019521320a8273769891ade /main/x264
parentd218307c3f5ca3bb714075368f71f8c7332371cb (diff)
downloadaports-a4bde33c11ae0e960f722f6e6904eedd42f3c532.tar.bz2
aports-a4bde33c11ae0e960f722f6e6904eedd42f3c532.tar.xz
main/x264: disable aggresive loop optimizations
ref #2485
Diffstat (limited to 'main/x264')
-rw-r--r--main/x264/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/x264/APKBUILD b/main/x264/APKBUILD
index 6f3435ff4..e766e0ac3 100644
--- a/main/x264/APKBUILD
+++ b/main/x264/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=x264
pkgver=20130409
-pkgrel=1
+pkgrel=2
pkgdesc="free library for encoding H264/AVC video streams"
url="http://www.videolan.org/developers/x264.html"
arch="all"
@@ -12,7 +12,7 @@ subpackages="$pkgname-dev"
source="ftp://ftp.videolan.org/pub/x264/snapshots/x264-snapshot-$pkgver-2245-stable.tar.bz2"
_builddir="$srcdir/$pkgname-snapshot-$pkgver-2245-stable"
-build() {
+build() {
cd "$_builddir"
local _asmopts=
@@ -30,6 +30,7 @@ build() {
--enable-shared \
$_asmopts \
--enable-pic \
+ --extra-cflags=-fno-aggressive-loop-optimizations \
|| return 1
make || return 1
}