summaryrefslogtreecommitdiffstats
path: root/main/xen
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-09 13:23:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-09 13:24:55 +0000
commit0ce588554409c2a50d047cfd6868bf2203fde8ca (patch)
tree9e2a43c3b4d4be568e40b754ae878d5724b2fdf2 /main/xen
parentca97d4721e0060e4e548799170be38c2f62d7a50 (diff)
downloadaports-0ce588554409c2a50d047cfd6868bf2203fde8ca.tar.bz2
aports-0ce588554409c2a50d047cfd6868bf2203fde8ca.tar.xz
main/xen: fix filename clash with qemu and cleanup
Diffstat (limited to 'main/xen')
-rw-r--r--main/xen/APKBUILD23
-rw-r--r--main/xen/fix-pod2man-choking.patch37
-rw-r--r--main/xen/librt.patch11
-rw-r--r--main/xen/qemu-xen-sysconfdir.patch10
-rw-r--r--main/xen/qemu-xen_paths.patch11
-rw-r--r--main/xen/xen-xend.post-install10
-rw-r--r--main/xen/xen-xend.post-upgrade10
7 files changed, 18 insertions, 94 deletions
diff --git a/main/xen/APKBUILD b/main/xen/APKBUILD
index 6799cfc25..9377c6d25 100644
--- a/main/xen/APKBUILD
+++ b/main/xen/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xen
pkgver=4.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="Xen hypervisor"
url="http://www.xen.org/"
arch="x86_64"
@@ -17,15 +17,11 @@ makedepends="$depends_dev autoconf automake libtool"
install=""
subpackages="$pkgname-doc $pkgname-dev $pkgname-libs $pkgname-hypervisor"
source="http://bits.xensource.com/oss-xen/release/$pkgver/$pkgname-$pkgver.tar.gz
- librt.patch
-
xsa108.patch
- fix-pod2man-choking.patch
-
qemu-coroutine-gthread.patch
qemu-xen-musl-openpty.patch
- qemu-xen-sysconfdir.patch
+ qemu-xen_paths.patch
hotplug-vif-vtrill.patch
0001-ipxe-dont-clobber-ebp.patch
@@ -168,6 +164,7 @@ package() {
libs() {
pkgdesc="Libraries for Xen tools"
replaces="xen"
+ depends=
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/*.so.* \
"$pkgdir"/usr/lib/fs \
@@ -176,18 +173,16 @@ libs() {
hypervisor() {
pkgdesc="Xen hypervisor"
- replaces="xen"
+ depends=
mkdir -p "$subpkgdir"
mv "$pkgdir"/boot "$subpkgdir"/
}
md5sums="1868433f393503000877d15cd4e93d15 xen-4.4.1.tar.gz
-2dc5ddf47c53ea168729975046c3c1f9 librt.patch
1f66f6c52941309c825f60e1bf144987 xsa108.patch
-4c5455d1adc09752a835e241097fbc39 fix-pod2man-choking.patch
de1a3db370b87cfb0bddb51796b50315 qemu-coroutine-gthread.patch
dd8603eaab5857816843bfc37647d569 qemu-xen-musl-openpty.patch
-80f5eeed326916ca46ca158b8049a4b9 qemu-xen-sysconfdir.patch
+c4d2d95ae3e5f538b7145becb3c6098e qemu-xen_paths.patch
e449bb3359b490804ffc7b0ae08d62a0 hotplug-vif-vtrill.patch
229539a822e14a6a62babffd71ecfbf3 0001-ipxe-dont-clobber-ebp.patch
08a30d56902b660f5102a5c208e545c9 init-xenstore-domain.patch
@@ -205,12 +200,10 @@ ec2252c72050d7d5870a3a629b873ba6 xenconsoled.confd
6a2f777c16678d84039acf670d86fff6 xenqemu.confd
f9afbf39e2b5a7d9dde60ebbd249ea7d xenqemu.initd"
sha256sums="55b49d3c4575d7791275125ff87c0f86f1d1e0f7f2718b6fd1c4f88a9bc7ea25 xen-4.4.1.tar.gz
-12bf32f9937b09283f2df4955b50d6739768f66137a7d991f661f45cf77cb53b librt.patch
cf7ecf4b4680c09e8b1f03980d8350a0e1e7eb03060031788f972e0d4d47203e xsa108.patch
-fcb5b9ff0bc4b4d39fed9b88891491b91628aa449914cfea321abe5da24c1da2 fix-pod2man-choking.patch
3941f99b49c7e8dafc9fae8aad2136a14c6d84533cd542cc5f1040a41ef7c6fe qemu-coroutine-gthread.patch
fe76c7c8faf686060b20491bfed4a13ce37b1bc3dcdbf33d242e388cee14c7c1 qemu-xen-musl-openpty.patch
-40a865f8bf69fc50780b1a1c87785c630ded832913a6b1a41b80111d94ff3cdb qemu-xen-sysconfdir.patch
+a6ccc0ed0dab8465188f92ceb3c983f10d65cd93bb2c8bab4e4155ef13536f5d qemu-xen_paths.patch
dd1e784bc455eb62cb85b3fa24bfc34f575ceaab9597ef6a2f1ee7ff7b3cae0a hotplug-vif-vtrill.patch
751ef06569de66578b8713dc170976832b0671ac2696f32eb9ad69d60332d594 0001-ipxe-dont-clobber-ebp.patch
0204d69804e83864cd6b2122f51b9c1940588158a35c159a7ef0c3b8fb0af4cb init-xenstore-domain.patch
@@ -228,12 +221,10 @@ c304a6353ba1daebd0547bb57e9ffffc2c90465d6abe7469cfdacf61c5108eab xendomains.ini
4cfcddcade5d055422ab4543e8caa6e5c5eee7625c41880a9000b7a87c7c424e xenqemu.confd
bf17808a79c57a9efc38b9f14cc87f556b2bb7ecfdec5763d9cf686255a47fce xenqemu.initd"
sha512sums="bcd577014f4e8cb37b934f17a4dfb6f12e72e865a9e553cc435fdbe6665c733a4d20a812bf126727eca0946188a6abbd9419579757d7e03a38059f3656371c1c xen-4.4.1.tar.gz
-74e3cfc51e367fc445cb3d8149f0c8830e94719a266daf04d2cd0889864591860c4c8842de2bc78070e4c5be7d14dfbb8b236c511d5faeddc2ad97177c1d3764 librt.patch
f511a13ee4223ea2fa9d109fea1802b462f178d3be7de630aeba6eb40ef5d17c7db9d3b99ea414c5794d92d181a60c0bd2061f51987c6deb3a9071f5626fd049 xsa108.patch
-2e95ad43bb66f928fe1e8caf474a3211571f75f79ea32aaa3eddb3aed9963444bd131006b67e682395af0d79118b2634bf808404693b813a94662d2a9d665ac2 fix-pod2man-choking.patch
c3c46f232f0bd9f767b232af7e8ce910a6166b126bd5427bb8dc325aeb2c634b956de3fc225cab5af72649070c8205cc8e1cab7689fc266c204f525086f1a562 qemu-coroutine-gthread.patch
a8b7378516172389450834985e8558d7a86d7cd808154bdc846bb98325e40fc4e87b1fc6d725297f4bef6eb54ebcbcbfa4d9d0363d83f635755795fb0726e006 qemu-xen-musl-openpty.patch
-4e314647801613a09b2ec4bf48baabed51451c3479c1ffb218959e2dca514f67463797097dfaf867d1cff48455fd08053a61c43721091808c60cd8f95b308b35 qemu-xen-sysconfdir.patch
+1f19cf495142dfc9f1786af6d4f7d497a482119fa2f1c10d4f9174994d38562719bc5190820dd444c32da0fb9af78fadac8dc8958437c26d6ca385f2409794e8 qemu-xen_paths.patch
f095ea373f36381491ad36f0662fb4f53665031973721256b23166e596318581da7cbb0146d0beb2446729adfdb321e01468e377793f6563a67d68b8b0f7ffe3 hotplug-vif-vtrill.patch
c3a1b270347a99c8ce21118010ad8d817b4462a31cc5c75352faa7086969ef0646f3f4d0922d85c2e504cff091ce7e9fe79c92f983c2ba4af2fae85c52c3835a 0001-ipxe-dont-clobber-ebp.patch
475eb800660dc928914b8c15562f18f24d6e7a76f4cc7bed9249ce52d444c29aec1aef843eb37ade0c7c9616195bbbc1606a3195e25b2bd4b6a1d1af5f69256e init-xenstore-domain.patch
diff --git a/main/xen/fix-pod2man-choking.patch b/main/xen/fix-pod2man-choking.patch
deleted file mode 100644
index 2b875ddc6..000000000
--- a/main/xen/fix-pod2man-choking.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- xen-4.2.2.orig/tools/qemu-xen/qemu-doc.texi
-+++ xen-4.2.2/tools/qemu-xen/qemu-doc.texi
-@@ -225,7 +225,7 @@
- QEMU uses YM3812 emulation by Tatsuyuki Satoh.
-
- QEMU uses GUS emulation (GUSEMU32 @url{http://www.deinmeister.de/gusemu/})
--by Tibor "TS" Schütz.
-+by Tibor "TS" Schultz.
-
- Note that, by default, GUS shares IRQ(7) with parallel ports and so
- qemu must be told to not have parallel ports to have working GUS
---- xen-4.2.2.orig/docs/man/xl.cfg.pod.5
-+++ xen-4.2.2/docs/man/xl.cfg.pod.5
-@@ -680,9 +680,11 @@
-
- =back
-
-+Please see F<docs/misc/tscmode.txt> for more information on this option.
-+
- =back
-
--Please see F<docs/misc/tscmode.txt> for more information on this option.
-+=over 4
-
- =item B<localtime=BOOLEAN>
-
---- xen-4.3.0.orig/docs/man/xl.cfg.pod.5
-+++ xen-4.3.0/docs/man/xl.cfg.pod.5
-@@ -962,6 +962,8 @@
-
- =back
-
-+=back
-+
- =head3 Support for Paravirtualisation of HVM Guests
-
- The following options allow Paravirtualised features (such as devices)
diff --git a/main/xen/librt.patch b/main/xen/librt.patch
deleted file mode 100644
index 1964add35..000000000
--- a/main/xen/librt.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./tools/qemu-xen-traditional/Makefile.target.orig
-+++ ./tools/qemu-xen-traditional/Makefile.target
-@@ -520,7 +520,7 @@
- OBJS+=block-raw-posix.o
- endif
-
--LIBS+=-lz
-+LIBS+=-lz -lrt
- ifdef CONFIG_ALSA
- LIBS += -lasound
- endif
diff --git a/main/xen/qemu-xen-sysconfdir.patch b/main/xen/qemu-xen-sysconfdir.patch
deleted file mode 100644
index ad6387749..000000000
--- a/main/xen/qemu-xen-sysconfdir.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./tools/Makefile.orig
-+++ ./tools/Makefile
-@@ -189,6 +189,7 @@
- $$source/configure --enable-xen --target-list=i386-softmmu \
- $(QEMU_XEN_ENABLE_DEBUG) \
- --prefix=$(PREFIX) \
-+ --sysconfdir=/etc/xen \
- --source-path=$$source \
- --extra-cflags="-I$(XEN_ROOT)/tools/include \
- -I$(XEN_ROOT)/tools/libxc \
diff --git a/main/xen/qemu-xen_paths.patch b/main/xen/qemu-xen_paths.patch
new file mode 100644
index 000000000..79d634d6e
--- /dev/null
+++ b/main/xen/qemu-xen_paths.patch
@@ -0,0 +1,11 @@
+--- ./tools.orig/Makefile
++++ ./tools/Makefile
+@@ -198,6 +198,8 @@
+ --extra-ldflags="-L$(XEN_ROOT)/tools/libxc \
+ -L$(XEN_ROOT)/tools/xenstore" \
+ --bindir=$(LIBEXEC) \
++ --libexecdir=$(LIBEXEC) \
++ --sysconfdir=/etc/xen \
+ --datadir=$(SHAREDIR)/qemu-xen \
+ --localstatedir=/var \
+ --disable-kvm \
diff --git a/main/xen/xen-xend.post-install b/main/xen/xen-xend.post-install
deleted file mode 100644
index 9fc742fe5..000000000
--- a/main/xen/xen-xend.post-install
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-echo
-echo "*** DEPRECATION WARNING ***"
-echo "Support in Alpine for the xend toolstack is planned for removal in the Xen 4.5 packages."
-echo "We strongly recommend switching to the newer xl toolstack at earliest convenience."
-echo
-
-exit 0
-
diff --git a/main/xen/xen-xend.post-upgrade b/main/xen/xen-xend.post-upgrade
deleted file mode 100644
index 9fc742fe5..000000000
--- a/main/xen/xen-xend.post-upgrade
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-echo
-echo "*** DEPRECATION WARNING ***"
-echo "Support in Alpine for the xend toolstack is planned for removal in the Xen 4.5 packages."
-echo "We strongly recommend switching to the newer xl toolstack at earliest convenience."
-echo
-
-exit 0
-