summaryrefslogtreecommitdiffstats
path: root/main/xf86-video-modesetting
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-11 12:54:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-11 12:54:04 +0000
commit345661d65ab90202cd2385250555ebd144a6e5d0 (patch)
tree65f2bef4e15978bf5237ac414017b78b3fd7bd6b /main/xf86-video-modesetting
parentf8b50277f61b4eb54a2c20b5c9a8fe9a1a5dbd22 (diff)
downloadaports-345661d65ab90202cd2385250555ebd144a6e5d0.tar.bz2
aports-345661d65ab90202cd2385250555ebd144a6e5d0.tar.xz
main/xf86-video-modesetting: add patch from upstream
Diffstat (limited to 'main/xf86-video-modesetting')
-rw-r--r--main/xf86-video-modesetting/APKBUILD17
-rw-r--r--main/xf86-video-modesetting/drmmode_shadow.patch44
2 files changed, 55 insertions, 6 deletions
diff --git a/main/xf86-video-modesetting/APKBUILD b/main/xf86-video-modesetting/APKBUILD
index accf3c13a..ebb511ec1 100644
--- a/main/xf86-video-modesetting/APKBUILD
+++ b/main/xf86-video-modesetting/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-modesetting
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="X.org generic modesetting video drive"
url="http://cgit.freedesktop.org/xorg/driver/xf86-video-modesetting/"
arch="all"
-license="custom"
+license="MIT"
depends=""
depends_dev="xorg-server-dev udev-dev libdrm-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc"
-source="http://xorg.freedesktop.org/releases/individual/driver/xf86-video-modesetting-$pkgver.tar.bz2"
+source="http://xorg.freedesktop.org/releases/individual/driver/xf86-video-modesetting-$pkgver.tar.bz2
+ drmmode_shadow.patch
+ "
_builddir="$srcdir"/xf86-video-modesetting-$pkgver
prepare() {
@@ -42,6 +44,9 @@ package() {
rm "$pkgdir"/usr/lib/xorg/modules/*/*.la || return 1
}
-md5sums="da588d4f54111c2deae035998058ce10 xf86-video-modesetting-0.9.0.tar.bz2"
-sha256sums="90cf085573203dfadd48ea69bd694c4d04ccbe088b6855e9c85c34bb8a95d75c xf86-video-modesetting-0.9.0.tar.bz2"
-sha512sums="0e581deb3f09e932475c1ebf1e5a69239f6e0ac4d37bcc25ee9bc30083c1285c4a5645df960c7bd7103584512eff4149463195a985f469bd24f52059fd487cec xf86-video-modesetting-0.9.0.tar.bz2"
+md5sums="da588d4f54111c2deae035998058ce10 xf86-video-modesetting-0.9.0.tar.bz2
+9b1ea59cf9cb3987b3703fdf48f824bd drmmode_shadow.patch"
+sha256sums="90cf085573203dfadd48ea69bd694c4d04ccbe088b6855e9c85c34bb8a95d75c xf86-video-modesetting-0.9.0.tar.bz2
+91c22639428c871ea52ef8eee2b286f47ceaafe5c979303014dbe54c5ba9365e drmmode_shadow.patch"
+sha512sums="0e581deb3f09e932475c1ebf1e5a69239f6e0ac4d37bcc25ee9bc30083c1285c4a5645df960c7bd7103584512eff4149463195a985f469bd24f52059fd487cec xf86-video-modesetting-0.9.0.tar.bz2
+98c6bd20ce0a71b307e3d8f7d9e75892dbd586f029fb2385ff36de1d9e2bf09171bec5c2bf497f149488d48b0738a93db20fc7b04e43840e540bf1ed6a6dc534 drmmode_shadow.patch"
diff --git a/main/xf86-video-modesetting/drmmode_shadow.patch b/main/xf86-video-modesetting/drmmode_shadow.patch
new file mode 100644
index 000000000..0ac80078b
--- /dev/null
+++ b/main/xf86-video-modesetting/drmmode_shadow.patch
@@ -0,0 +1,44 @@
+From 91571cce03adc58a10b5d76307629efc7c994c3e Mon Sep 17 00:00:00 2001
+From: Rob Clark <robdclark@gmail.com>
+Date: Tue, 26 Aug 2014 17:31:26 -0400
+Subject: modesetting: Don't pretend to support rotation
+
+It only ends in tears
+
+Signed-off-by: Rob Clark <robdclark@gmail.com>
+Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
+
+diff --git a/src/drmmode_display.c b/src/drmmode_display.c
+index c533324..12aa987 100644
+--- a/src/drmmode_display.c
++++ b/src/drmmode_display.c
+@@ -568,17 +568,6 @@ drmmode_set_scanout_pixmap(xf86CrtcPtr crtc, PixmapPtr ppix)
+ }
+ #endif
+
+-static void *drmmode_shadow_allocate(xf86CrtcPtr crtc, int width, int height)
+-{
+- return NULL;
+-}
+-
+-static PixmapPtr drmmode_shadow_create(xf86CrtcPtr crtc, void *data, int width,
+- int height)
+-{
+- return NULL;
+-}
+-
+ static const xf86CrtcFuncsRec drmmode_crtc_funcs = {
+ .dpms = drmmode_crtc_dpms,
+ .set_mode_major = drmmode_set_mode_major,
+@@ -593,8 +582,6 @@ static const xf86CrtcFuncsRec drmmode_crtc_funcs = {
+ #ifdef MODESETTING_OUTPUT_SLAVE_SUPPORT
+ .set_scanout_pixmap = drmmode_set_scanout_pixmap,
+ #endif
+- .shadow_allocate = drmmode_shadow_allocate,
+- .shadow_create = drmmode_shadow_create,
+ };
+
+ static void
+--
+cgit v0.10.2
+