summaryrefslogtreecommitdiffstats
path: root/main/xmlrpc-c
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-11 06:42:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-11 08:00:57 +0000
commita6ccd58efc2e166154dcc775578afa4ccbcca1ad (patch)
tree7ba944d70079f5197c8a9605ccc7750c5776fdb7 /main/xmlrpc-c
parenteaa77f9c4c59d36d36fd210f35fe7967564b6033 (diff)
downloadaports-a6ccd58efc2e166154dcc775578afa4ccbcca1ad.tar.bz2
aports-a6ccd58efc2e166154dcc775578afa4ccbcca1ad.tar.xz
main/xmlrpc-c: upgrade to 1.25.29
Diffstat (limited to 'main/xmlrpc-c')
-rw-r--r--main/xmlrpc-c/APKBUILD23
-rw-r--r--main/xmlrpc-c/xmlrpc_abyss_exported.patch11
2 files changed, 25 insertions, 9 deletions
diff --git a/main/xmlrpc-c/APKBUILD b/main/xmlrpc-c/APKBUILD
index db77a6e23..bcf1398d5 100644
--- a/main/xmlrpc-c/APKBUILD
+++ b/main/xmlrpc-c/APKBUILD
@@ -1,17 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xmlrpc-c
-pkgver=1.25.28
+pkgver=1.25.29
pkgrel=0
pkgdesc="This library provides a modular implementation of XML-RPC for C and C++"
url="http://xmlrpc-c.sourceforge.net/"
arch="all"
-license="custom:xmlrpc-c"
+license="BSD and MIT"
depends=
makedepends="libtool curl-dev libxml2-dev zlib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-client
$pkgname-client++:clientxx xmlrpc-c++:cxx $pkgname-abyss"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tgz
- host-os-uclibc.patch"
+ host-os-uclibc.patch
+ xmlrpc_abyss_exported.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -82,9 +84,12 @@ abyss() {
"$subpkgdir"/usr/lib/
}
-md5sums="60c5e53f93089272cb5e26cec9f5da05 xmlrpc-c-1.25.28.tgz
-d3bee91077d3c7e1c0b80f6d7eeb2e63 host-os-uclibc.patch"
-sha256sums="0786022c6d82ea1af04efade5b86357196f572c458a9649c6c912c469cd93acf xmlrpc-c-1.25.28.tgz
-0aae483973387c710ddc6103be36287cfe507eaa2e998805e6aa858be8eeaaa5 host-os-uclibc.patch"
-sha512sums="e52508d6cc94501deb239dbbdd0f1fa00033052e7c3de145e519b535dfe6d3a94d8475544c21d1e1d41711231161cf9f8f0591505bbf551f5b0e17859e1e0e54 xmlrpc-c-1.25.28.tgz
-30b57c5ffd65ea9781a56d1b4535e53c9d51c16e00d269992b239f1ff611fe3a510eb72b4d6ee96100706161d40738bbdf109580c745bfc9899d540ca6b3f1e5 host-os-uclibc.patch"
+md5sums="cc8d9838c869ffecef4cf98370177544 xmlrpc-c-1.25.29.tgz
+d3bee91077d3c7e1c0b80f6d7eeb2e63 host-os-uclibc.patch
+4631f544608d65b5fa7c3464b6b9abf2 xmlrpc_abyss_exported.patch"
+sha256sums="c8d31334019cdad93be75bfbb2541bbaee2889215877de1016e78a72d5757227 xmlrpc-c-1.25.29.tgz
+0aae483973387c710ddc6103be36287cfe507eaa2e998805e6aa858be8eeaaa5 host-os-uclibc.patch
+932fc35baca5fc6664b8d032ca203337243022ee72506df150020ee612509d63 xmlrpc_abyss_exported.patch"
+sha512sums="68d842d9ba8b70370ac6455dc207df3f16ff359ccd43233938c4ee3f7faa4105f00796d0180ba7f7ad900db6214568dc46a066407fbed42a308ed862ac88e48b xmlrpc-c-1.25.29.tgz
+30b57c5ffd65ea9781a56d1b4535e53c9d51c16e00d269992b239f1ff611fe3a510eb72b4d6ee96100706161d40738bbdf109580c745bfc9899d540ca6b3f1e5 host-os-uclibc.patch
+a76479f5ef406aa0ed26834d352307925d7d4a8f41a1562a20309e93824ac8f72c8a337c18cea7850f80b571ea2a063ccbf0d5b0a0a1daeb82d3c615b6b38eb1 xmlrpc_abyss_exported.patch"
diff --git a/main/xmlrpc-c/xmlrpc_abyss_exported.patch b/main/xmlrpc-c/xmlrpc_abyss_exported.patch
new file mode 100644
index 000000000..ee82be3dc
--- /dev/null
+++ b/main/xmlrpc-c/xmlrpc_abyss_exported.patch
@@ -0,0 +1,11 @@
+--- ./include/xmlrpc-c/abyss.h.orig
++++ ./include/xmlrpc-c/abyss.h
+@@ -432,7 +432,7 @@
+ const char * const user,
+ const char * const pass);
+
+-XMLRPC_ABYSS_EXPORTED
++XMLRPC_DLLEXPORT
+ abyss_bool
+ ResponseAddField(TSession * const sessionP,
+ const char * const name,