summaryrefslogtreecommitdiffstats
path: root/main/xvinfo
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-16 18:59:35 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-16 18:59:35 +0000
commitad50583419748c326be8fdf2c3cea1100096f2ff (patch)
tree6ea8af3ad107a30dd30e7e688c5d4da645c53498 /main/xvinfo
parentced1e02903a233c6ca2a36e816cea9fd6946f0ed (diff)
downloadaports-ad50583419748c326be8fdf2c3cea1100096f2ff.tar.bz2
aports-ad50583419748c326be8fdf2c3cea1100096f2ff.tar.xz
main/{xev,xvinfo}: update config.sub and apkbuild
Diffstat (limited to 'main/xvinfo')
-rw-r--r--main/xvinfo/APKBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/main/xvinfo/APKBUILD b/main/xvinfo/APKBUILD
index 8e28a1221..00640e57e 100644
--- a/main/xvinfo/APKBUILD
+++ b/main/xvinfo/APKBUILD
@@ -10,9 +10,15 @@ subpackages="$pkgname-doc"
makedepends="pkgconfig libxv-dev"
depends=
source="http://xorg.freedesktop.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
-build ()
-{
- cd "$srcdir"/$pkgname-$pkgver
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -20,6 +26,10 @@ build ()
--mandir=/usr/share/man \
|| return 1
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}