summaryrefslogtreecommitdiffstats
path: root/main/yajl/libm.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-25 13:19:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-25 13:19:32 +0000
commit51551bb3763497122f88db3c996946c0d96ac62e (patch)
tree02b0a51dae8753f59390f2e25f97006bb9537c5d /main/yajl/libm.patch
parent6308aa0eef0e7cfec8c5fe4e5b10d2b5c924d0fe (diff)
downloadaports-51551bb3763497122f88db3c996946c0d96ac62e.tar.bz2
aports-51551bb3763497122f88db3c996946c0d96ac62e.tar.xz
main/yajl: moved frrom testing
Diffstat (limited to 'main/yajl/libm.patch')
-rw-r--r--main/yajl/libm.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/yajl/libm.patch b/main/yajl/libm.patch
new file mode 100644
index 000000000..9d22369ec
--- /dev/null
+++ b/main/yajl/libm.patch
@@ -0,0 +1,45 @@
+diff --git a/example/CMakeLists.txt b/example/CMakeLists.txt
+index 29cee35..387366e 100644
+--- a/example/CMakeLists.txt
++++ b/example/CMakeLists.txt
+@@ -20,4 +20,4 @@ LINK_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
+
+ ADD_EXECUTABLE(parse_config ${SRCS})
+
+-TARGET_LINK_LIBRARIES(parse_config yajl_s)
++TARGET_LINK_LIBRARIES(parse_config yajl_s m)
+diff --git a/reformatter/CMakeLists.txt b/reformatter/CMakeLists.txt
+index da4032b..d48e218 100644
+--- a/reformatter/CMakeLists.txt
++++ b/reformatter/CMakeLists.txt
+@@ -26,7 +26,7 @@ LINK_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
+
+ ADD_EXECUTABLE(json_reformat ${SRCS})
+
+-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
++TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
+
+ # copy the binary into the output directory
+ GET_TARGET_PROPERTY(binPath json_reformat LOCATION)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index e36b736..85083bf 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -38,6 +38,7 @@ SET(LIBRARY_OUTPUT_PATH ${libDir})
+ ADD_LIBRARY(yajl_s STATIC ${SRCS} ${HDRS} ${PUB_HDRS})
+
+ ADD_LIBRARY(yajl SHARED ${SRCS} ${HDRS} ${PUB_HDRS})
++TARGET_LINK_LIBRARIES(yajl m)
+
+ #### setup shared library version number
+ SET_TARGET_PROPERTIES(yajl PROPERTIES
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index 153288c..c5fa974 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -20,4 +20,4 @@ LINK_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
+
+ ADD_EXECUTABLE(yajl_test ${SRCS})
+
+-TARGET_LINK_LIBRARIES(yajl_test yajl_s)
++TARGET_LINK_LIBRARIES(yajl_test yajl_s m)