summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-29 13:42:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-29 13:43:46 +0000
commit853f2871416a49e7dbe31d0bca29cbbcc9114878 (patch)
treecbca9be4179ce0da7ef73420afc11ab8dedf9051 /main
parent22e63da01a59489436f8d9a52337195a6e7083bc (diff)
downloadaports-853f2871416a49e7dbe31d0bca29cbbcc9114878.tar.bz2
aports-853f2871416a49e7dbe31d0bca29cbbcc9114878.tar.xz
main/obexd: remove. merged into bluez 5
http://www.bluez.org/release-of-bluez-5-0/
Diffstat (limited to 'main')
-rw-r--r--main/obexd/APKBUILD59
-rw-r--r--main/obexd/include-unistd.h.patch11
2 files changed, 0 insertions, 70 deletions
diff --git a/main/obexd/APKBUILD b/main/obexd/APKBUILD
deleted file mode 100644
index ab25b29b9..000000000
--- a/main/obexd/APKBUILD
+++ /dev/null
@@ -1,59 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=obexd
-pkgver=0.46
-pkgrel=1
-pkgdesc="D-Bus service for Obex Server"
-url="http://www.bluez.org/"
-arch="all"
-license="GPL2"
-depends="!obex-data-server"
-subpackages="$pkgname-client"
-makedepends="dbus-glib-dev openobex-dev glib-dev bluez-dev libical-dev"
-source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2
- include-unistd.h.patch"
-
-prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --libexecdir=/usr/lib/obexd \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install
-}
-
-_mv_files() {
- local i
- for i in "$@"; do
- mkdir -p "$subpkgdir"/${i%/*}
- mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
- done
-}
-
-client() {
- pkgdesc="D-Bus service for Obex Client access"
- depends=
- cd "$pkgdir"
- _mv_files usr/lib/obexd/obex-client \
- usr/share/dbus-*/services/obex-client.service
-}
-
-md5sums="625f0417d119437429c9cce29479cfa4 obexd-0.46.tar.bz2
-be080a04628bf1c53f86ba205d99161a include-unistd.h.patch"
diff --git a/main/obexd/include-unistd.h.patch b/main/obexd/include-unistd.h.patch
deleted file mode 100644
index 921407d25..000000000
--- a/main/obexd/include-unistd.h.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/obexd-0.46/mas.c.orig
-+++ b/obexd-0.46/plugins/mas.c
-@@ -30,6 +30,7 @@
- #include <glib.h>
- #include <fcntl.h>
- #include <inttypes.h>
-+#include <unistd.h>
-
- #include <gobex/gobex.h>
-
-