summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-05-06 13:28:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-05-06 13:30:14 +0000
commit53bd6b11cb34bd5bf4835da96c4370565554808e (patch)
treee60227ffe1b710a185e8fecf39de94cefc29af32 /main
parentc212a0c4ad2cea5de0b448cece335500e3bebd36 (diff)
downloadaports-53bd6b11cb34bd5bf4835da96c4370565554808e.tar.bz2
aports-53bd6b11cb34bd5bf4835da96c4370565554808e.tar.xz
main/alpine-conf: upgrade to 3.2.0
Diffstat (limited to 'main')
-rw-r--r--main/alpine-conf/0001-setup-apkcache-fix-infinite-loop-when-non-existing-d.patch33
-rw-r--r--main/alpine-conf/0001-setup-disk-fix-typo.patch25
-rw-r--r--main/alpine-conf/0001-setup-disk-pass-nomodeset-boot-option.patch42
-rw-r--r--main/alpine-conf/0001-update-kernel-fix-typo.patch25
-rw-r--r--main/alpine-conf/APKBUILD26
5 files changed, 5 insertions, 146 deletions
diff --git a/main/alpine-conf/0001-setup-apkcache-fix-infinite-loop-when-non-existing-d.patch b/main/alpine-conf/0001-setup-apkcache-fix-infinite-loop-when-non-existing-d.patch
deleted file mode 100644
index ed3191d2b..000000000
--- a/main/alpine-conf/0001-setup-apkcache-fix-infinite-loop-when-non-existing-d.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From b0b109a06f1f890b8833c6afa38c357a084c65bc Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 19 Mar 2015 12:44:41 +0000
-Subject: [PATCH] setup-apkcache: fix infinite loop when non-existing dir
- specified
-
-to reproduce: setup-apkcache /ponies
-
-ref #3976
----
- setup-apkcache.in | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/setup-apkcache.in b/setup-apkcache.in
-index 0e578c8..5210d82 100644
---- a/setup-apkcache.in
-+++ b/setup-apkcache.in
-@@ -47,10 +47,10 @@ find_mount_point() {
- fi
-
- local dir="$1"
-- while ! [ -d "$dir" ]; do
-+ while [ -n "$dir" ] && ! [ -d "$dir" ]; do
- dir=${dir%/*}
- done
-- local fs_id=$(stat -f -c %i "$dir")
-+ local fs_id=$(stat -f -c %i "${dir:-/}")
- local parent="${dir%/*}"
- while [ -n "$dir" ] && [ "$(stat -f -c %i $parent/)" = "$fs_id" ]; do
- dir=$parent
---
-2.3.3
-
diff --git a/main/alpine-conf/0001-setup-disk-fix-typo.patch b/main/alpine-conf/0001-setup-disk-fix-typo.patch
deleted file mode 100644
index 50886aa99..000000000
--- a/main/alpine-conf/0001-setup-disk-fix-typo.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 34d5c6cd766e9565c09721004f68f570b40da857 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 19 Mar 2015 12:23:46 +0000
-Subject: [PATCH] setup-disk: fix typo
-
----
- setup-disk.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup-disk.in b/setup-disk.in
-index f4401dd..ad9684e 100644
---- a/setup-disk.in
-+++ b/setup-disk.in
-@@ -460,7 +460,7 @@ confirm_erase() {
- local answer=
- local erasedisks="$@"
- if [ "$ERASE_DISKS" = "$erasedisks" ]; then
-- reeturn 0
-+ return 0
- fi
- echo "WARNING: The following disk(s) will be erased:"
- show_disk_info $@
---
-2.3.3
-
diff --git a/main/alpine-conf/0001-setup-disk-pass-nomodeset-boot-option.patch b/main/alpine-conf/0001-setup-disk-pass-nomodeset-boot-option.patch
deleted file mode 100644
index a93258383..000000000
--- a/main/alpine-conf/0001-setup-disk-pass-nomodeset-boot-option.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 547603a359aa1fd2ba69c8dcb0cddeecd6d5a169 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 3 Dec 2014 10:43:32 +0000
-Subject: [PATCH] setup-disk: pass nomodeset boot option
-
----
- setup-disk.in | 12 ++++++++++++
- 1 file changed, 12 insertions(+)
-
-diff --git a/setup-disk.in b/setup-disk.in
-index bae373a..f4401dd 100644
---- a/setup-disk.in
-+++ b/setup-disk.in
-@@ -185,6 +185,15 @@ cleanup_chroot_mounts() {
- done
- }
-
-+has_bootopt() {
-+ local opt="$1"
-+ set -- $(cat /proc/cmdline)
-+ for i; do
-+ [ "$i" = "$opt" ] && return 0
-+ done
-+ return 1
-+}
-+
- install_mounted_root() {
- local mnt="$1" mnt_boot= boot_fs= root_fs=
- local initfs_features="ata base ide scsi usb virtio"
-@@ -275,6 +284,9 @@ install_mounted_root() {
- if is_vmware; then
- kernel_opts="pax_nouderef $kernel_opts"
- fi
-+ if has_bootopt nomodeset; then
-+ kernel_opts="nomodeset $kernel_opts"
-+ fi
- modules="sd-mod,usb-storage,${root_fs}${raidmod}"
- sed -e "s:^root=.*:root=$root:" \
- -e "s:^default_kernel_opts=.*:default_kernel_opts=\"$kernel_opts\":" \
---
-2.2.0
-
diff --git a/main/alpine-conf/0001-update-kernel-fix-typo.patch b/main/alpine-conf/0001-update-kernel-fix-typo.patch
deleted file mode 100644
index e0deb97dc..000000000
--- a/main/alpine-conf/0001-update-kernel-fix-typo.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From a800358ceff81134a2538e50298eaff240dbcc94 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 21 Nov 2014 12:40:55 +0000
-Subject: [PATCH] update-kernel: fix typo
-
----
- update-kernel.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/update-kernel.in b/update-kernel.in
-index 09b6b9e..2ae397e 100644
---- a/update-kernel.in
-+++ b/update-kernel.in
-@@ -130,7 +130,7 @@ trap clean_up EXIT $SIGNALS
-
-
- if [ "$SUPERUSER" ]; then
-- apk add $QUIET_OPT --update--cache -t $VIRTUAL mkinitfs squashfs-tools
-+ apk add $QUIET_OPT --update-cache -t $VIRTUAL mkinitfs squashfs-tools
- fi
-
- if [ -z "$features" ]; then
---
-2.1.3
-
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index e0224c933..9543807aa 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,17 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
-pkgver=3.1.0
-pkgrel=4
+pkgver=3.2.0
+pkgrel=0
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
arch="all"
license="GPL2"
depends="openrc"
source="http://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.xz
- 0001-update-kernel-fix-typo.patch
- 0001-setup-disk-pass-nomodeset-boot-option.patch
- 0001-setup-disk-fix-typo.patch
- 0001-setup-apkcache-fix-infinite-loop-when-non-existing-d.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -38,18 +34,6 @@ package() {
done
}
-md5sums="d48adaa13dbba0e4c461b39a59fb1c10 alpine-conf-3.1.0.tar.xz
-fe4a81cdf9d30c1f0bbcc9977e96410a 0001-update-kernel-fix-typo.patch
-4b7844387da57e3ffdcd1e09c0a45fb6 0001-setup-disk-pass-nomodeset-boot-option.patch
-968fac093f66bb6e92f24cbf1d1cbeaf 0001-setup-disk-fix-typo.patch
-2f5532e2447ba7af4549fb3826cfbda4 0001-setup-apkcache-fix-infinite-loop-when-non-existing-d.patch"
-sha256sums="5c5c3081fba18c0303bd29ccf8caab5d550c0a767f9b3b1e6a0644b717661122 alpine-conf-3.1.0.tar.xz
-cc1a2254eae01c2cde362cc7cf65d6e5ba7d53a7ced8a170b0502130af6877be 0001-update-kernel-fix-typo.patch
-a5e486f41dafdca904e1d67b2bb26d871e6ec9597295e1fc21ea5d8995986570 0001-setup-disk-pass-nomodeset-boot-option.patch
-e03066193c158d489b0169c6ec7fbbce2fedba23e28e92d40a5d9ab4920c8102 0001-setup-disk-fix-typo.patch
-0e07cae6ac39618a6da6393bcbc7e9c4bb74524376b5f1beaee02bb8d0a99659 0001-setup-apkcache-fix-infinite-loop-when-non-existing-d.patch"
-sha512sums="22ce9a149171cf8503937b60d36ec2b69fb95123d3e3f7776cc3c9e0f14cdc8a9a2338be8c223233652cd1456f6b55bbc71ed0deda2efb75f0e62b67a4c40088 alpine-conf-3.1.0.tar.xz
-7f30c7ecb696b4fbf815802bd9d369f2d21a2b2502efdeac3af260df72195c19199fddc81702eb204746146433a23c0649bcf1b8a71c57a34971c4457f0ac33f 0001-update-kernel-fix-typo.patch
-3ff38ab78bc0a07762c7c3668cf4daaa4ca2d030ef148e61de6dbb1df4589fd2c844c992f35ce64aa9cc3125d7422ba9deb727259cc68a61e7f6d6ff22de16f7 0001-setup-disk-pass-nomodeset-boot-option.patch
-c6f32b0b03d0d9eadc6206fadeeaf8c7e0880dc5e556374bbf9334ed7ec8f38257f6afe4ddbc7c634c6cc722609ab8bfcd1897d586661d33b2cc6dd087edc4c1 0001-setup-disk-fix-typo.patch
-23be2445278768e0ed830290a569206b1cdc9941abe2d2fa1b6a7aa120f580e974d8df75fb218b70ac3ddccffd9450d2ce64b334a5e3ec004c8c369f2c3c87d4 0001-setup-apkcache-fix-infinite-loop-when-non-existing-d.patch"
+md5sums="db580800445157df07c681722aab4b6b alpine-conf-3.2.0.tar.xz"
+sha256sums="9a2d1b23ba9f19ecdd07798d79f8ab6ba63ea28daa1cbbf19da8bd1c2e6b9484 alpine-conf-3.2.0.tar.xz"
+sha512sums="9e1b41d94212596693d7e98f3a310b0576c86628ed528a1f112fab72bc4d14e88d99a7bedf834563e0337ccf0b256a450e47bfb3a4dd4935130fcd503d35f2ea alpine-conf-3.2.0.tar.xz"