summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-05-07 08:52:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-05-07 08:52:07 +0000
commit5d2312354ee20be8165bebd3575c1b3953f7aab5 (patch)
tree2c9b88c8ef982994513c4334df9dd04698e998d3 /main
parent43504c6916baa9eb95bbac5060ed8a4190bf6902 (diff)
downloadaports-5d2312354ee20be8165bebd3575c1b3953f7aab5.tar.bz2
aports-5d2312354ee20be8165bebd3575c1b3953f7aab5.tar.xz
main/redis: upgrade to 3.0.1
Diffstat (limited to 'main')
-rw-r--r--main/redis/APKBUILD22
-rw-r--r--main/redis/fix-musl-stdint.patch95
2 files changed, 9 insertions, 108 deletions
diff --git a/main/redis/APKBUILD b/main/redis/APKBUILD
index a89c4ccd0..f96b00b99 100644
--- a/main/redis/APKBUILD
+++ b/main/redis/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: V.Krishn <vkrishn4@gmail.com>
# Maintainer: Eivind Uggedal <eivind@uggedal.com>
pkgname=redis
-pkgver=3.0.0
-pkgrel=1
+pkgver=3.0.1
+pkgrel=0
pkgdesc="Advanced key-value store"
url="http://redis.io/"
arch="all"
@@ -15,11 +15,10 @@ subpackages=""
pkgusers="redis"
pkggroups="redis"
source="http://download.redis.io/releases/$pkgname-$pkgver.tar.gz
- fix-musl-stdint.patch
- redis.initd
- redis.logrotate
- redis.confd
- "
+ redis.initd
+ redis.logrotate
+ redis.confd
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -72,18 +71,15 @@ package() {
}
-md5sums="cd8487159459d7575ba2664cb2a4819e redis-3.0.0.tar.gz
-0a1a0419c833a3686a50570a8ecc6e91 fix-musl-stdint.patch
+md5sums="dd2bf1f65d75ed518313158086d4219b redis-3.0.1.tar.gz
e284cbbb7fcddbcb573bcd8318366316 redis.initd
ed0a5e40633e82c52c50f8bf0ed93ae0 redis.logrotate
bf204d560e41b854297c60aff8d862d5 redis.confd"
-sha256sums="654c95c6236692dcb916fccba9a34d0877cc91338c8b6a372511e6eb080e34bf redis-3.0.0.tar.gz
-ba2cce83d0e3f8fd055b3d645700e70c7f1ba324132e7e549ac87d7f8ee40c02 fix-musl-stdint.patch
+sha256sums="0e21be5d7c5e6ab6adcbed257619897db59be9e1ded7ef6fd1582d0cdb5e5bb7 redis-3.0.1.tar.gz
0cc974108792aa49c7d2cddcb0d53c4223acdf38652ffac6b6b76e835ebcaf78 redis.initd
aa078c4757fc426710310a0688cc1ab728acb7a2afa648e28b2ecbd57d003c0d redis.logrotate
97d50b2bee2df995317b505d459c31fe4abe74e670028f0335febdd6e4e31486 redis.confd"
-sha512sums="c7403eaa58dcdb8c85d53531b262a07099fc38ecb5e4e41622ad9355d356ecd269d691f15ef65da9fb9241395c2a3cb72eea27325d632b7cd8eaf3c4d2e3fe72 redis-3.0.0.tar.gz
-2134b5df538eda5140214b0ba720ddd5a3a612d6856d01140001bbb787ce1242d3c847c5ab553cf690ca780078cded527a25fe3a0e4afd3c953719fe04e390e4 fix-musl-stdint.patch
+sha512sums="53261fa8e45d2c83758b5ba8f17e3c93c74e5d20e2d94829bb564e2436281e161759f824a294e3c73fc17e700724190711f7bd51282547a443e94f323d574430 redis-3.0.1.tar.gz
91b663f802aea9a473195940d3bf2ce3ca2af4e5b6e61a2d28ebbfe502ef2c764b574b7e87c49e60345d1a5d6b73d12920924c93b26be110c2ce824023347b6f redis.initd
6d17d169b40a7e23a0a2894eff0f3e2fe8e4461b36f2a9d45468f0abd84ea1035d679b4c0a34029bce093147f9c7bb697e843c113c17769d38c934d4a78a5848 redis.logrotate
d87aad6185300c99cc9b6a478c83bf62c450fb2c225592d74cc43a3adb93e19d8d2a42cc279907b385aa73a7b9c77b66828dbfb001009edc16a604abb2087e99 redis.confd"
diff --git a/main/redis/fix-musl-stdint.patch b/main/redis/fix-musl-stdint.patch
deleted file mode 100644
index 5914e5688..000000000
--- a/main/redis/fix-musl-stdint.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-From 6056a76392b52a5b38e57aec2c7ca46b748df298 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 2 Apr 2015 08:27:16 +0200
-Subject: [PATCH] sha1: use standard uint32_t integer type
-
-Use the C99 standard uint32_t type instead of the implementation
-specific u_int32_t.
-
-This fixes the following compile error when building with musl libc:
-
- In file included from sha1.c:28:0:
- sha1.h:11:5: error: unknown type name 'u_int32_t'
- u_int32_t state[5];
- ^
----
- src/sha1.c | 14 +++++++-------
- src/sha1.h | 10 ++++++----
- 2 files changed, 13 insertions(+), 11 deletions(-)
-
-diff --git a/src/sha1.c b/src/sha1.c
-index 7f73b40..e65b59b 100644
---- a/src/sha1.c
-+++ b/src/sha1.c
-@@ -23,7 +23,7 @@ A million repetitions of "a"
-
- #include <stdio.h>
- #include <string.h>
--#include <sys/types.h> /* for u_int*_t */
-+#include <stdint.h> /* for uint*_t */
- #include "solarisfixes.h"
- #include "sha1.h"
- #include "config.h"
-@@ -53,12 +53,12 @@ A million repetitions of "a"
-
- /* Hash a single 512-bit block. This is the core of the algorithm. */
-
--void SHA1Transform(u_int32_t state[5], const unsigned char buffer[64])
-+void SHA1Transform(uint32_t state[5], const unsigned char buffer[64])
- {
-- u_int32_t a, b, c, d, e;
-+ uint32_t a, b, c, d, e;
- typedef union {
- unsigned char c[64];
-- u_int32_t l[16];
-+ uint32_t l[16];
- } CHAR64LONG16;
- #ifdef SHA1HANDSOFF
- CHAR64LONG16 block[1]; /* use array to appear as a pointer */
-@@ -128,9 +128,9 @@ void SHA1Init(SHA1_CTX* context)
-
- /* Run your data through this. */
-
--void SHA1Update(SHA1_CTX* context, const unsigned char* data, u_int32_t len)
-+void SHA1Update(SHA1_CTX* context, const unsigned char* data, uint32_t len)
- {
-- u_int32_t i, j;
-+ uint32_t i, j;
-
- j = context->count[0];
- if ((context->count[0] += len << 3) < j)
-@@ -168,7 +168,7 @@ void SHA1Final(unsigned char digest[20], SHA1_CTX* context)
-
- for (i = 0; i < 2; i++)
- {
-- u_int32_t t = context->count[i];
-+ uint32_t t = context->count[i];
- int j;
-
- for (j = 0; j < 4; t >>= 8, j++)
-diff --git a/src/sha1.h b/src/sha1.h
-index 4c76d19..92e3528 100644
---- a/src/sha1.h
-+++ b/src/sha1.h
-@@ -7,15 +7,17 @@ By Steve Reid <steve@edmweb.com>
- 100% Public Domain
- */
-
-+#include <stdint.h>
-+
- typedef struct {
-- u_int32_t state[5];
-- u_int32_t count[2];
-+ uint32_t state[5];
-+ uint32_t count[2];
- unsigned char buffer[64];
- } SHA1_CTX;
-
--void SHA1Transform(u_int32_t state[5], const unsigned char buffer[64]);
-+void SHA1Transform(uint32_t state[5], const unsigned char buffer[64]);
- void SHA1Init(SHA1_CTX* context);
--void SHA1Update(SHA1_CTX* context, const unsigned char* data, u_int32_t len);
-+void SHA1Update(SHA1_CTX* context, const unsigned char* data, uint32_t len);
- void SHA1Final(unsigned char digest[20], SHA1_CTX* context);
-
- #ifdef REDIS_TEST