summaryrefslogtreecommitdiffstats
path: root/testing/apts
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-23 09:45:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-23 09:45:52 +0000
commitab94ef2af563557737db9d3d4baa00c1e3d352fd (patch)
treeeff819f4f346dff7cd1a42b93e6e24607fb402b5 /testing/apts
parentb4b7cc065e124c2dc73458710fc0d40007478ce4 (diff)
downloadaports-ab94ef2af563557737db9d3d4baa00c1e3d352fd.tar.bz2
aports-ab94ef2af563557737db9d3d4baa00c1e3d352fd.tar.xz
testing/apts: new aport
APTS - Alpine Package Testing Suite http://git.alpinelinux.org/cgit/apts/
Diffstat (limited to 'testing/apts')
-rw-r--r--testing/apts/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/apts/APKBUILD b/testing/apts/APKBUILD
new file mode 100644
index 000000000..ba6813c4e
--- /dev/null
+++ b/testing/apts/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Jeff Bilyk <jbilyk@gmail.com>
+pkgname=apts
+pkgver=0.1
+_pkgver="master"
+pkgrel=0
+pkgdesc="APTS - Alpine Package Testing Suite"
+depends=
+makedepends=
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$_pkgver.tar.bz2
+ "
+url="http://git.alpinelinux.org/cgit/apts/"
+arch="x86 x86_64"
+license=GPL-2
+
+build() {
+ echo "Nothing to build, moving on to package"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$_pkgver"
+ mkdir -p "$pkgdir"/etc/apts
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share/$pkgname/tests
+ mkdir -p "$pkgdir"/usr/share/docs/$pkgname
+
+ install -m755 -D $pkgname "$pkgdir"/usr/bin/$pkgname
+ install -m644 -D apts.conf "$pkgdir"/etc/$pkgname/${pkgname}.conf
+ install -m644 -D README "$pkgdir"/usr/share/docs/$pkgname/README
+ install -m644 -D missing-tests "$pkgdir"/usr/share/docs/$pkgname/missing-tests
+ install -m644 -D torvalds-says-linux.mp3 "$pkgdir"/usr/share/$pkgname/torvalds-says-linux.mp3
+ install -m644 -D test.rar "$pkgdir"/usr/share/$pkgname/test.rar
+ for i in `ls tests`; do
+ install -m644 -D tests/$i "$pkgdir"/usr/share/$pkgname/tests/$i
+ done
+}
+
+md5sums="0eead32c26a0224f9f7afcc013fc8f52 apts-master.tar.bz2"