summaryrefslogtreecommitdiffstats
path: root/testing/asterisk/APKBUILD
diff options
context:
space:
mode:
authorTimo Teras <timo.teras@iki.fi>2009-03-11 17:57:15 +0200
committerTimo Teras <timo.teras@iki.fi>2009-03-11 17:57:15 +0200
commitc4a61b70d3194fe0cf90e5945bb83842fec96c28 (patch)
tree645483f8eac1c751cfb32997450679ffcebcd381 /testing/asterisk/APKBUILD
parent666e5259b9d4d31eff65d24799ebe61f682d2603 (diff)
downloadaports-c4a61b70d3194fe0cf90e5945bb83842fec96c28.tar.bz2
aports-c4a61b70d3194fe0cf90e5945bb83842fec96c28.tar.xz
testing/asterisk: initial commit
it puts everything to a big monster .apk. a lot of work is still needed to split it into approriate sub packages and test them. but this is a good starting point.
Diffstat (limited to 'testing/asterisk/APKBUILD')
-rw-r--r--testing/asterisk/APKBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/testing/asterisk/APKBUILD b/testing/asterisk/APKBUILD
new file mode 100644
index 000000000..736004ab9
--- /dev/null
+++ b/testing/asterisk/APKBUILD
@@ -0,0 +1,66 @@
+# Contributor: Timo Teras <timo.teras@iki.fi>
+# Maintainer: Timo Teras <timo.teras@iki.fi>
+pkgname=asterisk
+pkgver=1.6.1-rc1
+pkgrel=1
+pkgdesc="Asterisk: A Module Open Source PBX System"
+url="http://www.asterisk.org/"
+license="GPL"
+depends="ncurses popt zlib newt dahdi-linux dahdi-tools libltdl"
+makedepends="autoconf automake libtool ncurses-dev popt-dev newt-dev zlib-dev postgresql-dev unixodbc-dev dahdi-tools-dev libpri-dev"
+install="$pkgname.pre-install $pkgname.post-install"
+subpackages="$pkgname-doc"
+source="http://downloads.digium.com/pub/asterisk/releases/$pkgname-$pkgver.tar.gz
+ asterisk-01-1.6.0-gsm-pic.patch
+ asterisk-02-1.6.0-uclibc.patch
+ asterisk-03-1.6.1-rc1-i14292.patch
+ asterisk-04-1.6.0-beta7.1-caps-uclibc.patch
+ asterisk-05-1.6.1-glob-uclibc.patch
+ asterisk-06-overlapped-enum.patch
+ asterisk.pre-install
+ asterisk.post-install
+ asterisk.initd
+ asterisk.confd"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for i in ../*.patch; do
+ msg "Apply $i"
+ patch -p1 < $i || return 1
+ done
+
+ sed -i -e 's/PBX_ICONV=1/PBX_ICONV=0/g' configure.ac
+
+ ./bootstrap.sh
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-xmldoc --with-gsm=internal \
+ --without-iconv --with-popt --with-z --with-newt \
+ --with-odbc --with-postgres \
+ --with-dahdi --with-pri --with-tonezone
+
+ # and figure out which modules to build
+ rm menuselect.makeopts
+ make menuselect.makeopts
+ make -j1 || return 1
+ make -j1 DESTDIR="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="29f7285b673d52b49d91c8e797acbbb0 asterisk-1.6.1-rc1.tar.gz
+97b39fd9777a2521d4f9f095482b7ac2 asterisk-01-1.6.0-gsm-pic.patch
+53b0b2a1527972722a50c8c5b560e63e asterisk-02-1.6.0-uclibc.patch
+0ea488c4f4412b160b91e5f9bda0498b asterisk-03-1.6.1-rc1-i14292.patch
+929f740db7043b4553544ebcc7315c91 asterisk-04-1.6.0-beta7.1-caps-uclibc.patch
+c37928e95ebef36aad097accfdbbfcb8 asterisk-05-1.6.1-glob-uclibc.patch
+1b49f980e56dc7ce493a046eadff3545 asterisk-06-overlapped-enum.patch
+b4a97cb1ec3cc3f71a10ce8c067ab430 asterisk.pre-install
+2188be223f93923e04a8e812cf54e97c asterisk.post-install
+bbcd152417bb7c838b25cb6007db91da asterisk.initd
+ed31d7ba37bcf8b0346dcf8593c395f0 asterisk.confd"