summaryrefslogtreecommitdiffstats
path: root/testing/cherokee/APKBUILD
diff options
context:
space:
mode:
authorMika Havela <mika.havela@gmail.com>2010-01-01 21:30:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-05 13:11:24 +0000
commitdceab94dac458d2c90f16581a2816b539352342a (patch)
tree1375e6d57d1c2b3343e61aecd48e921cf4914d5d /testing/cherokee/APKBUILD
parent631ec650573e7d81865caf6fd7b94320845c1173 (diff)
downloadaports-dceab94dac458d2c90f16581a2816b539352342a.tar.bz2
aports-dceab94dac458d2c90f16581a2816b539352342a.tar.xz
cherokee: New APKBUILD for cherokee web server http://www.cherokee-project.com/
Diffstat (limited to 'testing/cherokee/APKBUILD')
-rw-r--r--testing/cherokee/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/cherokee/APKBUILD b/testing/cherokee/APKBUILD
new file mode 100644
index 000000000..6568e23d9
--- /dev/null
+++ b/testing/cherokee/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+pkgname=cherokee
+pkgver=0.99.38
+pkgrel=0
+pkgdesc="A very fast, flexible and easy to configure Web Server"
+url="http://www.cherokee-project.com/"
+license="GPL2"
+depends="pcre"
+makedepends="openssl-dev gettext-dev ffmpeg-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://www.cherokee-project.com/download/0.99/${pkgver}/${pkgname}-${pkgver}.tar.gz
+ cherokee.initd
+ "
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ --with-wwwroot=/var/www
+# --mandir=/usr/share/man \
+# --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="67be28eda0673598fbb5b1cbd70de455 cherokee-0.99.38.tar.gz
+4180dbb6701f928054079aa1e3bd5ebc cherokee.initd"