summaryrefslogtreecommitdiffstats
path: root/testing/cmus
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-12 18:41:51 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-12 18:41:51 +0200
commitca281c03fb074164640c48cd37f43e3e07681b75 (patch)
treea172da56fb1a531e675b2d5f2f88c4ec931fa66d /testing/cmus
parent041e9814320274f3625540df53f398ca4fd255b3 (diff)
downloadaports-ca281c03fb074164640c48cd37f43e3e07681b75.tar.bz2
aports-ca281c03fb074164640c48cd37f43e3e07681b75.tar.xz
testing/cmus: new aport
Diffstat (limited to 'testing/cmus')
-rw-r--r--testing/cmus/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/cmus/APKBUILD b/testing/cmus/APKBUILD
new file mode 100644
index 000000000..88decd21e
--- /dev/null
+++ b/testing/cmus/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=cmus
+pkgver=2.4.3
+pkgrel=0
+pkgdesc='A very feature-rich ncurses-based music player'
+url='http://cmus.sourceforge.net/'
+license='GPL'
+arch='all'
+makedepends='alsa-lib-dev faad2-dev flac-dev libiconv-dev libmad-dev libogg-dev libvorbis-dev ncurses-dev wavpack-dev'
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-v$pkgver.tar.bz2"
+
+build() {
+ LDFLAGS="$LDFLAGS -liconv"
+ cd "$srcdir"/$pkgname-v$pkgver
+ ./configure prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-v$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="75452cf007637214c4ab5444e076114b cmus-v2.4.3.tar.bz2"