summaryrefslogtreecommitdiffstats
path: root/testing/ddate
diff options
context:
space:
mode:
authorJohannes Matheis <jomat+alpinebuild@jmt.gr>2014-10-23 08:35:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-23 14:31:34 +0000
commitccc0e2b0ce4c66fae4c3b87b68667bae931a8373 (patch)
tree9c4c485e1359be5d9bb2d82740ec26dc93eb15d2 /testing/ddate
parenta56da86bc3bea1f2fcbba99b7826b0ea771eb5d4 (diff)
downloadaports-ccc0e2b0ce4c66fae4c3b87b68667bae931a8373.tar.bz2
aports-ccc0e2b0ce4c66fae4c3b87b68667bae931a8373.tar.xz
testing/ddate: new aport
https://github.com/bo0ts/ddate Convert Gregorian dates to Discordian dates
Diffstat (limited to 'testing/ddate')
-rw-r--r--testing/ddate/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/ddate/APKBUILD b/testing/ddate/APKBUILD
new file mode 100644
index 000000000..68fb3b72a
--- /dev/null
+++ b/testing/ddate/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+pkgname=ddate
+pkgver=0.2.2
+pkgrel=0
+pkgdesc="Convert Gregorian dates to Discordian dates"
+url="https://github.com/bo0ts/ddate"
+arch="all"
+license="custom"
+depends=""
+depends_dev=""
+makedepends="$depends_dev cmake"
+install=""
+subpackages="$pkgname-doc"
+source="${url}/archive/v${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+
+build() {
+ cd "$_builddir"
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make PREFIX="/usr"
+}
+
+package() {
+ cd "$_builddir/build"
+ make DESTDIR="${pkgdir}" install
+}
+
+md5sums="154ead3444d60806c97919b4f3d69e19 v0.2.2.tar.gz"
+sha256sums="d53c3f0af845045f39d6d633d295fd4efbe2a792fd0d04d25d44725d11c678ad v0.2.2.tar.gz"
+sha512sums="5d148e030bee392eb93c5ae519061af0736f2f75eaae916e3efaf927d9f4de8cc72afc4a5121b6fbc0264b73e9f580330a38b97bb78837d447d0b4c1fc29ec06 v0.2.2.tar.gz"