summaryrefslogtreecommitdiffstats
path: root/testing/dhcpdump
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-08-14 13:48:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-08-14 13:48:46 +0000
commita906a45db5743e92da75924aca78a48caea20558 (patch)
tree4680d465352d33d364b2ceb87a2ec9c1c83af343 /testing/dhcpdump
parentf76cf6ed9972aa2edbfeed9efcbfb8074b47514a (diff)
downloadaports-a906a45db5743e92da75924aca78a48caea20558.tar.bz2
aports-a906a45db5743e92da75924aca78a48caea20558.tar.xz
testing/dhcpdump: new aport
utility to analyze sniffed DHCP packets http://www.mavetju.org/unix/general.php
Diffstat (limited to 'testing/dhcpdump')
-rw-r--r--testing/dhcpdump/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/dhcpdump/APKBUILD b/testing/dhcpdump/APKBUILD
new file mode 100644
index 000000000..deb397b67
--- /dev/null
+++ b/testing/dhcpdump/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dhcpdump
+pkgver=1.8
+pkgrel=0
+pkgdesc="utility to analyze sniffed DHCP packets"
+url="http://www.mavetju.org/unix/general.php"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libpcap-dev perl"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.mavetju.org/download/dhcpdump-$pkgver.tar.gz"
+
+_builddir="$srcdir"/dhcpdump-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D dhcpdump "$pkgdir"/usr/bin/dhcpdump || return 1
+ install -D dhcpdump.8 "$pkgdir"/usr/share/man/man8/dhcpdump.8 \
+ || return 1
+}
+
+md5sums="099c786997c424f196414f9575f1fb90 dhcpdump-1.8.tar.gz"
+sha256sums="6d5eb9418162fb738bc56e4c1682ce7f7392dd96e568cc996e44c28de7f77190 dhcpdump-1.8.tar.gz"
+sha512sums="52cd63d581a3c530c2f5baa66808d5b0241853651c720bd513b769b8301b4dff9c87243787014aea98a5b3ebed86ec317b58d262bf5031015141a4da50fb76e6 dhcpdump-1.8.tar.gz"