summaryrefslogtreecommitdiffstats
path: root/testing/dvtm
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-07-19 21:59:07 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-07-19 21:59:07 +0200
commit3037298ac0ea6d1da9becc31fa3cdde3fe48d361 (patch)
treec4ded01f76cdf5b83d69d558932d8b8f69a7a934 /testing/dvtm
parent73b4a1dcdba7069e89199160974159a3c4b9a6f0 (diff)
downloadaports-3037298ac0ea6d1da9becc31fa3cdde3fe48d361.tar.bz2
aports-3037298ac0ea6d1da9becc31fa3cdde3fe48d361.tar.xz
testing/dvtm: new aport
Diffstat (limited to 'testing/dvtm')
-rw-r--r--testing/dvtm/0001-Makefile-respect-DESTDIR-in-tic-invocation.patch25
-rw-r--r--testing/dvtm/APKBUILD46
-rw-r--r--testing/dvtm/config.h157
3 files changed, 228 insertions, 0 deletions
diff --git a/testing/dvtm/0001-Makefile-respect-DESTDIR-in-tic-invocation.patch b/testing/dvtm/0001-Makefile-respect-DESTDIR-in-tic-invocation.patch
new file mode 100644
index 000000000..9ce462240
--- /dev/null
+++ b/testing/dvtm/0001-Makefile-respect-DESTDIR-in-tic-invocation.patch
@@ -0,0 +1,25 @@
+From 4ab5ed57a3b53e0271cf50f256cd7904c50cac55 Mon Sep 17 00:00:00 2001
+From: Douglas Jerome <douglas@ttylinux.org>
+Date: Wed, 15 May 2013 14:33:31 +0200
+Subject: [PATCH] Makefile: respect ${DESTDIR} in tic invocation
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index ff85deb..eb849f4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -55,7 +55,7 @@ install: dvtm
+ @sed "s/VERSION/${VERSION}/g" < dvtm.1 > ${DESTDIR}${MANPREFIX}/man1/dvtm.1
+ @chmod 644 ${DESTDIR}${MANPREFIX}/man1/dvtm.1
+ @echo installing terminfo description
+- @tic -s dvtm.info
++ @tic -o ${DESTDIR}/usr/share/terminfo -s dvtm.info
+
+ uninstall:
+ @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+--
+1.8.3.450.gf3f2a46
+
diff --git a/testing/dvtm/APKBUILD b/testing/dvtm/APKBUILD
new file mode 100644
index 000000000..48f589ba8
--- /dev/null
+++ b/testing/dvtm/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=dvtm
+pkgver=0.9
+pkgrel=0
+pkgdesc='Dynamic virtual terminal manager'
+arch='all'
+url='http://www.brain-dump.org/projects/dvtm/'
+license='MIT'
+makedepends='ncurses-dev'
+source="http://www.brain-dump.org/projects/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ config.h
+ 0001-Makefile-respect-DESTDIR-in-tic-invocation.patch"
+
+prepare() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ patch -Np1 -i \
+ "$srcdir"/0001-Makefile-respect-DESTDIR-in-tic-invocation.patch \
+ || return 1
+
+ cp "${srcdir}"/config.h .
+ sed -i 's/CFLAGS =/CFLAGS +=/' config.mk || return 1
+}
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+
+ make PREFIX=/usr DESTDIR="${pkgdir}" install || return 1
+ install -Dm0644 LICENSE \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE || return 1
+}
+md5sums="7de1103abb0ca410f7250cf89f019a38 dvtm-0.9.tar.gz
+41107e5e84a8572f70d6cb111b4e07f8 config.h
+c85d8265ced45d014a7d3f05134bf6a1 0001-Makefile-respect-DESTDIR-in-tic-invocation.patch"
+sha256sums="c751fb5778ecd24465c0db0e5ab9ac0a3e0dd61ab006708d6168fd609e81aa98 dvtm-0.9.tar.gz
+df4b7e544ebb65d5da87f28388c175ea11a48d8df657996372a658be651951df config.h
+0eb584e1f66ebc264f31364da9e54e425d0cbd95f93cbbf1ec34cfc1b37161a6 0001-Makefile-respect-DESTDIR-in-tic-invocation.patch"
+sha512sums="33c6f32510b17c0dcb3c8a216fd8c4cde14d6874495a9e0992c2104fda2ee7edb9a40de25c2efc84337b6f61858c1bf3e0e4ed5d77ab4d2db01ddfa02c1d4eaa dvtm-0.9.tar.gz
+34a610311a9716b98fe197f82b14c1cd38f69ee0b562f23a987e910eaef07bf57963495f5ce15922c5e4568bc84f875c9be239d6821fb6dd8b08cdeb3aaa472b config.h
+31dce735c16f6750991f7d7ca8735c5407923253c489fe6f2bda739fd98771f571592e102b41a47ca1633dbea118b757cf4ecc285c517c4a869e6d0e4bed8329 0001-Makefile-respect-DESTDIR-in-tic-invocation.patch"
diff --git a/testing/dvtm/config.h b/testing/dvtm/config.h
new file mode 100644
index 000000000..48367695a
--- /dev/null
+++ b/testing/dvtm/config.h
@@ -0,0 +1,157 @@
+/* valid curses attributes are listed below they can be ORed
+ *
+ * A_NORMAL Normal display (no highlight)
+ * A_STANDOUT Best highlighting mode of the terminal.
+ * A_UNDERLINE Underlining
+ * A_REVERSE Reverse video
+ * A_BLINK Blinking
+ * A_DIM Half bright
+ * A_BOLD Extra bright or bold
+ * A_PROTECT Protected mode
+ * A_INVIS Invisible or blank mode
+ */
+#define BLUE (COLORS==256 ? 68 : COLOR_BLUE)
+/* curses attributes for the currently focused window */
+#define SELECTED_ATTR COLOR(BLUE, -1) | A_NORMAL
+/* curses attributes for normal (not selected) windows */
+#define NORMAL_ATTR COLOR(-1, -1) | A_NORMAL
+/* curses attributes for the status bar */
+#define BAR_ATTR COLOR(BLUE, -1) | A_NORMAL
+/* status bar (command line option -s) position */
+#define BAR_POS BAR_TOP /* BAR_BOTTOM, BAR_OFF */
+/* determines whether the statusbar text should be right or left aligned */
+#define BAR_ALIGN ALIGN_RIGHT
+/* separator between window title and window number */
+#define SEPARATOR " | "
+/* printf format string for the window title, first %s
+ * is replaced by the title, second %s is replaced by
+ * the SEPARATOR, %d stands for the window number */
+#define TITLE "[%s%s#%d]"
+/* master width factor [0.1 .. 0.9] */
+#define MFACT 0.5
+/* scroll back buffer size in lines */
+#define SCROLL_HISTORY 500
+
+#include "tile.c"
+#include "grid.c"
+#include "bstack.c"
+#include "fullscreen.c"
+
+/* by default the first layout entry is used */
+static Layout layouts[] = {
+ { "[]=", tile },
+ { "+++", grid },
+ { "TTT", bstack },
+ { "[ ]", fullscreen },
+};
+
+#define MOD CTRL('g')
+
+/* you can at most specifiy MAX_ARGS (3) number of arguments */
+static Key keys[] = {
+ { MOD, 'c', { create, { NULL } } },
+ { MOD, 'C', { create, { NULL, NULL, "$CWD" } } },
+ { MOD, 'x', { killclient, { NULL } } },
+ { MOD, 'j', { focusnext, { NULL } } },
+ { MOD, 'u', { focusnextnm, { NULL } } },
+ { MOD, 'i', { focusprevnm, { NULL } } },
+ { MOD, 'k', { focusprev, { NULL } } },
+ { MOD, 't', { setlayout, { "[]=" } } },
+ { MOD, 'g', { setlayout, { "+++" } } },
+ { MOD, 'b', { setlayout, { "TTT" } } },
+ { MOD, 'm', { setlayout, { "[ ]" } } },
+ { MOD, ' ', { setlayout, { NULL } } },
+ { MOD, 'h', { setmfact, { "-0.05" } } },
+ { MOD, 'l', { setmfact, { "+0.05" } } },
+ { MOD, '.', { toggleminimize, { NULL } } },
+ { MOD, 's', { togglebar, { NULL } } },
+ { MOD, 'M', { togglemouse, { NULL } } },
+ { MOD, '\n', { zoom , { NULL } } },
+ { MOD, '1', { focusn, { "1" } } },
+ { MOD, '2', { focusn, { "2" } } },
+ { MOD, '3', { focusn, { "3" } } },
+ { MOD, '4', { focusn, { "4" } } },
+ { MOD, '5', { focusn, { "5" } } },
+ { MOD, '6', { focusn, { "6" } } },
+ { MOD, '7', { focusn, { "7" } } },
+ { MOD, '8', { focusn, { "8" } } },
+ { MOD, '9', { focusn, { "9" } } },
+ { MOD, 'q', { quit, { NULL } } },
+ { MOD, 'G', { escapekey, { NULL } } },
+ { MOD, 'a', { togglerunall, { NULL } } },
+ { MOD, 'r', { redraw, { NULL } } },
+ { MOD, 'X', { lock, { NULL } } },
+ { MOD, 'B', { togglebell, { NULL } } },
+ { MOD, 'v', { copymode, { NULL } } },
+ { MOD, '/', { copymode, { "/" } } },
+ { MOD, '?', { copymode, { "?" } } },
+ { MOD, 'p', { paste, { NULL } } },
+ { MOD, KEY_PPAGE, { scrollback, { "-1" } } },
+ { MOD, KEY_NPAGE, { scrollback, { "1" } } },
+ { MOD, KEY_F(1), { create, { "man dvtm", "dvtm help" } } },
+};
+
+static const ColorRule colorrules[] = {
+ { "", A_NORMAL, -1, -1 }, /* default */
+#if 0
+ /* title attrs fgcolor bgcolor */
+ { "ssh", A_NORMAL, COLOR_BLACK, 224 },
+#endif
+};
+
+/* possible values for the mouse buttons are listed below:
+ *
+ * BUTTON1_PRESSED mouse button 1 down
+ * BUTTON1_RELEASED mouse button 1 up
+ * BUTTON1_CLICKED mouse button 1 clicked
+ * BUTTON1_DOUBLE_CLICKED mouse button 1 double clicked
+ * BUTTON1_TRIPLE_CLICKED mouse button 1 triple clicked
+ * BUTTON2_PRESSED mouse button 2 down
+ * BUTTON2_RELEASED mouse button 2 up
+ * BUTTON2_CLICKED mouse button 2 clicked
+ * BUTTON2_DOUBLE_CLICKED mouse button 2 double clicked
+ * BUTTON2_TRIPLE_CLICKED mouse button 2 triple clicked
+ * BUTTON3_PRESSED mouse button 3 down
+ * BUTTON3_RELEASED mouse button 3 up
+ * BUTTON3_CLICKED mouse button 3 clicked
+ * BUTTON3_DOUBLE_CLICKED mouse button 3 double clicked
+ * BUTTON3_TRIPLE_CLICKED mouse button 3 triple clicked
+ * BUTTON4_PRESSED mouse button 4 down
+ * BUTTON4_RELEASED mouse button 4 up
+ * BUTTON4_CLICKED mouse button 4 clicked
+ * BUTTON4_DOUBLE_CLICKED mouse button 4 double clicked
+ * BUTTON4_TRIPLE_CLICKED mouse button 4 triple clicked
+ * BUTTON_SHIFT shift was down during button state change
+ * BUTTON_CTRL control was down during button state change
+ * BUTTON_ALT alt was down during button state change
+ * ALL_MOUSE_EVENTS report all button state changes
+ * REPORT_MOUSE_POSITION report mouse movement
+ */
+
+#ifdef NCURSES_MOUSE_VERSION
+# define CONFIG_MOUSE /* compile in mouse support if we build against ncurses */
+#endif
+
+#define ENABLE_MOUSE true /* whether to enable mouse events by default */
+
+#ifdef CONFIG_MOUSE
+static Button buttons[] = {
+ { BUTTON1_CLICKED, { mouse_focus, { NULL } } },
+ { BUTTON1_DOUBLE_CLICKED, { mouse_fullscreen, { "[ ]" } } },
+ { BUTTON2_CLICKED, { mouse_zoom, { NULL } } },
+ { BUTTON3_CLICKED, { mouse_minimize, { NULL } } },
+};
+#endif /* CONFIG_MOUSE */
+
+static Cmd commands[] = {
+ { "create", { create, { NULL } } },
+};
+
+/* gets executed when dvtm is started */
+static Action actions[] = {
+ { create, { NULL } },
+};
+
+static char const * const keytable[] = {
+ /* add your custom key escape sequences */
+};