summaryrefslogtreecommitdiffstats
path: root/testing/gparted
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-11-11 20:18:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-11-11 20:18:18 +0000
commit131a54a923eaf1431ab950b6315482bf9b739ee4 (patch)
treeaee3208ca76452a26b988b9be5e45dd3eeb182b6 /testing/gparted
parentf11d3a02f97bd667855cf5176ad368ba70c375d5 (diff)
downloadaports-131a54a923eaf1431ab950b6315482bf9b739ee4.tar.bz2
aports-131a54a923eaf1431ab950b6315482bf9b739ee4.tar.xz
testing/gparted: new aport
a graphical partition editor for creating, reorganizing, and deleting disk partitions http://gparted.sourceforge.net/
Diffstat (limited to 'testing/gparted')
-rw-r--r--testing/gparted/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/gparted/APKBUILD b/testing/gparted/APKBUILD
new file mode 100644
index 000000000..19b4d9853
--- /dev/null
+++ b/testing/gparted/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor:
+# Maintainer:
+pkgname=gparted
+pkgver=0.7.0
+pkgrel=0
+pkgdesc="a graphical partition editor for creating, reorganizing, and deleting disk partitions"
+url="http://gparted.sourceforge.net/"
+license="GPL"
+depends=
+makedepends="gtkmm-dev parted-dev util-linux-ng-dev"
+#gnome-doc-utils py-libxml2"
+install=
+subpackages="$pkgname-doc"
+source="http://sourceforge.net/projects/gparted/files/gparted/gparted-$pkgver/gparted-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-doc \
+ --disable-scrollkeeper
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="88c5b2162a7b7847c68ea80f4fcd0153 gparted-0.7.0.tar.bz2"