summaryrefslogtreecommitdiffstats
path: root/testing/gummiboot
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-01-08 21:20:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-01-08 21:20:16 +0000
commitaff7349e5da417ac968da94fb59c97b176593537 (patch)
tree960fba6e6aaa7fa2181e7a7a637418ab51367b84 /testing/gummiboot
parent1689430f6f0d0905140b2bf2de2e5edccc11ab06 (diff)
downloadaports-aff7349e5da417ac968da94fb59c97b176593537.tar.bz2
aports-aff7349e5da417ac968da94fb59c97b176593537.tar.xz
testing/gummiboot: new aport
Simple EFI Boot Manager http://freedesktop.org/wiki/Software/gummiboot
Diffstat (limited to 'testing/gummiboot')
-rw-r--r--testing/gummiboot/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/gummiboot/APKBUILD b/testing/gummiboot/APKBUILD
new file mode 100644
index 000000000..3c3996e42
--- /dev/null
+++ b/testing/gummiboot/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gummiboot
+pkgver=42
+pkgrel=0
+pkgdesc="Simple EFI Boot Manager"
+url="http://freedesktop.org/wiki/Software/gummiboot"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev="util-linux-dev"
+makedepends="$depends_dev gnu-efi-dev autoconf automake docbook-xsl libxslt"
+install=""
+subpackages="$pkgname-doc"
+#source="http://cgit.freedesktop.org/gummiboot/snapshot/gummiboot-$pkgver.tar.gz"
+source="http://dev.alpinelinux.org/archive/gummiboot/gummiboot-$pkgver.tar.gz"
+
+_builddir="$srcdir"/gummiboot-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ if ! [ -f ./configure ]; then
+ ./autogen.sh
+ fi
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="417d612a8b2e6e259a7c6df0b3ae4670 gummiboot-42.tar.gz"
+sha256sums="e3a40bd68d1ebcba60b0562564a61963544bde7e04c394743853dbd5ff3aa4f7 gummiboot-42.tar.gz"
+sha512sums="ee6f85eb7e20d9ed2c1fc6d4d5ef1def4f0335ee43d231d36597629fa8d5ea2861a7432c1274f09e0e52e04ed398aa66c543348bc7ab9c4004e41a06f4dc7d44 gummiboot-42.tar.gz"