summaryrefslogtreecommitdiffstats
path: root/testing/haserl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-07 13:26:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-07 13:31:16 +0000
commit20d9cf8f35cd0bc4506cfb2e4302deb18f10b405 (patch)
treeaa81018894ba56ebb0a3c121b7d4071262a7bbcf /testing/haserl
parent06757d02c022295864e516fd2ba2ae2de4a1d0cd (diff)
downloadaports-20d9cf8f35cd0bc4506cfb2e4302deb18f10b405.tar.bz2
aports-20d9cf8f35cd0bc4506cfb2e4302deb18f10b405.tar.xz
testing/lua: build against lua 5.2
Diffstat (limited to 'testing/haserl')
-rw-r--r--testing/haserl/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/haserl/APKBUILD b/testing/haserl/APKBUILD
new file mode 100644
index 000000000..ee1fd605e
--- /dev/null
+++ b/testing/haserl/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_luaver=5.2
+pkgname=haserl
+pkgver=0.9.32
+pkgrel=1
+pkgdesc="Html And Shell Embedded Report Language (with Lua $_luaver support)"
+url="http://haserl.sourceforge.net/"
+arch="all"
+license="GPL-2"
+depends=
+makedepends="lua$_luaver-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-lua=lua$_luaver \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir/" install
+ chmod 4111 "$pkgdir"/usr/bin/haserl
+}
+
+md5sums="18e2208aea6d772d1670c1a648bb6b77 haserl-0.9.32.tar.gz"
+sha256sums="c93aea462cddce1cda5a712f50bcad2197d987bdc01477ddb79347c0d4fae26f haserl-0.9.32.tar.gz"
+sha512sums="9ccd9037abade1f4654ea42c594218bac19668ad1485b6e40e1c50af76db69861ade4a80f420bc97b4a722047f239970297c52317f3071a31eaadba88a4f57b2 haserl-0.9.32.tar.gz"