summaryrefslogtreecommitdiffstats
path: root/testing/httest/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-05 13:59:35 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 14:35:08 +0200
commit3845837c83cfba8a758c6b56ea554e59afece8b1 (patch)
treea6925ea925e8b9805d00848e1d44c5149e18ec93 /testing/httest/APKBUILD
parentf65b013d565177074f4fee220385644836cf6984 (diff)
downloadaports-3845837c83cfba8a758c6b56ea554e59afece8b1.tar.bz2
aports-3845837c83cfba8a758c6b56ea554e59afece8b1.tar.xz
testing/httest: new aport
A script based tool for testing and benchmarking web applications http://htt.sourceforge.net
Diffstat (limited to 'testing/httest/APKBUILD')
-rw-r--r--testing/httest/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/httest/APKBUILD b/testing/httest/APKBUILD
new file mode 100644
index 000000000..dd084943a
--- /dev/null
+++ b/testing/httest/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=httest
+pkgver=2.4.8
+pkgrel=0
+pkgdesc="A script based tool for testing and benchmarking web applications"
+url="http://htt.sourceforge.net"
+arch="all"
+license="ASL 2.0"
+depends=""
+depends_dev=""
+makedepends="apr-dev apr-util-dev pcre-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/project/htt/htt2.4/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="e9f04f48136bbbd85463cf3d4049be14 httest-2.4.8.tar.gz"
+sha256sums="7c6cda4fced85ed0dd8e1e2b9053b9ff7db50a88843c4e2482e3fff601e5cb5c httest-2.4.8.tar.gz"
+sha512sums="2829d6cbd1ecb6aa602652350b4c4b317e653068a62d25e13d427cec6c2deda25481a1de14a2853987b224e5a942a06a26036e6ad503bb89356c18ed16da3a02 httest-2.4.8.tar.gz"