summaryrefslogtreecommitdiffstats
path: root/testing/httpie-oauth
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-25 07:57:10 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 14:07:38 +0000
commit010747b4e3de2c6b1f0ca14ace3468b2a17cb66f (patch)
treeb2f64fd06325fc9688e2c6efd1d908393e122e53 /testing/httpie-oauth
parent8429da6a43ae8f503dabc6c585b10540c25c0017 (diff)
downloadaports-010747b4e3de2c6b1f0ca14ace3468b2a17cb66f.tar.bz2
aports-010747b4e3de2c6b1f0ca14ace3468b2a17cb66f.tar.xz
testing/httpie-oauth: new aport
OAuth plugin for HTTPie https://github.com/jkbr/httpie-oauth
Diffstat (limited to 'testing/httpie-oauth')
-rw-r--r--testing/httpie-oauth/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/httpie-oauth/APKBUILD b/testing/httpie-oauth/APKBUILD
new file mode 100644
index 000000000..7ef7f9f34
--- /dev/null
+++ b/testing/httpie-oauth/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=httpie-oauth
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="OAuth plugin for HTTPie"
+url="https://github.com/jkbr/httpie-oauth"
+arch="noarch"
+license="BSD"
+depends="python httpie"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="5644a00d4648a0d2b8af7c3fcbe4e36c httpie-oauth-1.0.2.tar.gz"
+sha256sums="b4fd8c6e85a7f84e27ba7bfc910627e7010465f4dc4999f81f6c43513485503f httpie-oauth-1.0.2.tar.gz"
+sha512sums="d2825143e839f82591db59995619f7437fccc42e9f126ca247e19b1533706cfaadaab5c3518d3d994e898fcb3d98ed899cd9a36f07963d701eb019587c2821c6 httpie-oauth-1.0.2.tar.gz"