summaryrefslogtreecommitdiffstats
path: root/testing/kbuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-16 12:24:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-16 12:24:07 +0000
commit468668c8211152668d2246f4c165afbba9d66640 (patch)
tree579c0b642e0a0fede2a119f5a391e207066a68be /testing/kbuild
parente3f425398a07acc6aaf35477fb82583f12d8a829 (diff)
downloadaports-468668c8211152668d2246f4c165afbba9d66640.tar.bz2
aports-468668c8211152668d2246f4c165afbba9d66640.tar.xz
testing/kbuild: fix for kmk_sed and gcc-4.7
https://www.virtualbox.org/ticket/10160
Diffstat (limited to 'testing/kbuild')
-rw-r--r--testing/kbuild/APKBUILD4
-rw-r--r--testing/kbuild/kbuild-0.1.9998_pre20110817-gcc-4.7.patch12
2 files changed, 15 insertions, 1 deletions
diff --git a/testing/kbuild/APKBUILD b/testing/kbuild/APKBUILD
index 1d95fc838..ac1fc45fa 100644
--- a/testing/kbuild/APKBUILD
+++ b/testing/kbuild/APKBUILD
@@ -3,7 +3,7 @@
pkgname=kbuild
pkgver=0.1.9998_pre20120806
_ver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
pkgdesc="A makefile framework for writing simple makefiles for complex tasks"
url="http://svn.netlabs.org/kbuild/wiki"
arch="all"
@@ -19,6 +19,7 @@ source="http://dev.gentoo.org/~polynomial-c/kBuild-${_ver}-src.tar.xz
strlcpy.patch
underlinking.patch
sys_siglist.patch
+ kbuild-0.1.9998_pre20110817-gcc-4.7.patch
uclibc.patch"
_builddir="$srcdir"/kBuild-$_ver
@@ -65,4 +66,5 @@ b3dd26cc185c96658d9b554eef2f811c lchmod.patch
90cae3b53b4ec6fc5f1c336922083df0 strlcpy.patch
ca09174d7c885fdea1e3c2dc580d80b3 underlinking.patch
52c3450a3e2645f57871b0141c465776 sys_siglist.patch
+2fdb2fb96c48371b2a15785926c9144b kbuild-0.1.9998_pre20110817-gcc-4.7.patch
b3c2d0e6902f1285c09d81f74e573c4f uclibc.patch"
diff --git a/testing/kbuild/kbuild-0.1.9998_pre20110817-gcc-4.7.patch b/testing/kbuild/kbuild-0.1.9998_pre20110817-gcc-4.7.patch
new file mode 100644
index 000000000..435b3f57f
--- /dev/null
+++ b/testing/kbuild/kbuild-0.1.9998_pre20110817-gcc-4.7.patch
@@ -0,0 +1,12 @@
+diff -urN kBuild-0.1.9998-pre20110817-orig/src/sed/lib/regex_internal.c kBuild-0.1.9998-pre20110817/src/sed/lib/regex_internal.c
+--- kBuild-0.1.9998-pre20110817-orig/src/sed/lib/regex_internal.c 2011-08-17 14:28:42.000000000 -0700
++++ kBuild-0.1.9998-pre20110817/src/sed/lib/regex_internal.c 2012-06-16 13:55:05.341176965 -0700
+@@ -781,7 +781,7 @@
+ }
+
+ static unsigned char
+-internal_function __attribute ((pure))
++internal_function
+ re_string_fetch_byte_case (re_string_t *pstr)
+ {
+ if (BE (!pstr->mbs_allocated, 1))