summaryrefslogtreecommitdiffstats
path: root/testing/ladspa/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-04 22:07:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-04 22:07:55 +0000
commitf08d5081d923805de4db493c424dc73b402d481b (patch)
treea84883f17dbf86df93c2fd040986fea2b2f4e1d7 /testing/ladspa/APKBUILD
parent40ca5d808acd1a84983977fff3505cf2ba20a83f (diff)
downloadaports-f08d5081d923805de4db493c424dc73b402d481b.tar.bz2
aports-f08d5081d923805de4db493c424dc73b402d481b.tar.xz
testing/ladspa: new aport
Linux Audio Developer's Simple Plug-in API, examples and tools http://www.ladspa.org/
Diffstat (limited to 'testing/ladspa/APKBUILD')
-rw-r--r--testing/ladspa/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/ladspa/APKBUILD b/testing/ladspa/APKBUILD
new file mode 100644
index 000000000..573bccf9f
--- /dev/null
+++ b/testing/ladspa/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ladspa
+pkgver=1.13
+pkgrel=0
+pkgdesc="Linux Audio Developer's Simple Plug-in API, examples and tools"
+url="http://www.ladspa.org/"
+arch="all"
+license="LGPLv2+"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev"
+source="http://www.ladspa.org/download/ladspa_sdk_$pkgver.tgz
+ 0001-proper-build.patch
+ 0002-plugin-constructor-destructor.patch
+ 0003-plugindir.patch
+ "
+
+_builddir="$srcdir"/ladspa_sdk
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make -C src targets || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -C src install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="671be3e1021d0722cadc7fb27054628e ladspa_sdk_1.13.tgz
+0e834af5f341081b772848ed3a753d5d 0001-proper-build.patch
+4b5c8831519e7485f2dacc5663375872 0002-plugin-constructor-destructor.patch
+95943ab38a96051ff4a6caf33182634c 0003-plugindir.patch"