summaryrefslogtreecommitdiffstats
path: root/testing/libecap
diff options
context:
space:
mode:
authorRoger Newman <roger.newman@riseup.net>2014-10-10 09:51:21 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-10 11:52:52 +0000
commit1946daa8d790d5b40465ae143e127d28c66fb586 (patch)
tree1f71017db4495fb6e399b81dd5c1c938b1384b72 /testing/libecap
parentdf74969cdac1222f071ea9858c049069dbfd0a72 (diff)
downloadaports-1946daa8d790d5b40465ae143e127d28c66fb586.tar.bz2
aports-1946daa8d790d5b40465ae143e127d28c66fb586.tar.xz
testing/libecap: new aport
http://e-cap.org/Home eCAP allows an HTTP proxy or an ICAP server, to outsource content analysis and adaptation to a loadable module.
Diffstat (limited to 'testing/libecap')
-rw-r--r--testing/libecap/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/libecap/APKBUILD b/testing/libecap/APKBUILD
new file mode 100644
index 000000000..f88af93fa
--- /dev/null
+++ b/testing/libecap/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Roger Newman <roger.newman@riseup.net>
+pkgname=libecap
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="eCAP allows an HTTP proxy or an ICAP server, to outsource content analysis and adaptation to a loadable module"
+url="http://www.e-cap.org/"
+arch="all"
+license="BSD"
+depends=""
+subpackages="$pkgname-dev"
+source="http://www.measurement-factory.com/tmp/ecap/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --libdir=/lib \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install \
+ libdir=/usr/lib \
+ pkgconfigdir="/usr/lib/pkgconfig" \
+ DESTDIR="$pkgdir" || return 1
+
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="e65a855f4fbb0f3136af7fe28249e883 libecap-0.2.0.tar.gz"
+sha256sums="19e195d60cf67ec3b49fe4d109823d753546b5da115230499ad1a9cb65ca92d2 libecap-0.2.0.tar.gz"
+sha512sums="5d39444ec79846b14a7f4292e51bb880befd2cbf581b257d5087517cfae1dce55e4439a90c08e0b8f5b3e8b2431dde8c6fab771c826489024f17625cfc8c777e libecap-0.2.0.tar.gz"