summaryrefslogtreecommitdiffstats
path: root/testing/libical/APKBUILD
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-05-26 23:09:04 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-05-26 23:09:04 +0000
commit9fddb4d5b41c0b5e69d5ee138297e95eff290302 (patch)
treeb353402b4af0ac5b912dc78ca7d996c397b8e2e3 /testing/libical/APKBUILD
parentccf26410d30adc8c1934dd553687157ed6e31d69 (diff)
parent8c1128e93e03012dabadb9a3f723dbd20eb60cd4 (diff)
downloadaports-9fddb4d5b41c0b5e69d5ee138297e95eff290302.tar.bz2
aports-9fddb4d5b41c0b5e69d5ee138297e95eff290302.tar.xz
Merged from Alpine main repository.
Merge Conflicts: main/abuild/APKBUILD main/cramfs/APKBUILD main/curl/APKBUILD main/dialog/APKBUILD main/libconfig/APKBUILD main/snort/APKBUILD main/syslinux/APKBUILD
Diffstat (limited to 'testing/libical/APKBUILD')
-rw-r--r--testing/libical/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/libical/APKBUILD b/testing/libical/APKBUILD
new file mode 100644
index 000000000..22ef96784
--- /dev/null
+++ b/testing/libical/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libical
+pkgver=0.44
+pkgrel=0
+pkgdesc="An open source reference implementation of the icalendar data type and serialization format"
+url="http://sourceforge.net/projects/freeassociation/"
+license="LGPL MPL"
+depends=
+makedepends="perl"
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/freeassociation/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+md5sums="e0403c31e1ed82569325685f8c15959c libical-0.44.tar.gz"