summaryrefslogtreecommitdiffstats
path: root/testing/libtorrent/APKBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-04-14 10:46:40 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-04-19 15:35:53 +0200
commit14152028a43e2ed3604c7f4272ec27d45d2da943 (patch)
tree5fc83e13ecadcdac2546257268a3bca382e07aac /testing/libtorrent/APKBUILD
parent0a570078bbded2980e416c9827dc5a1ed5ae2c9e (diff)
downloadaports-14152028a43e2ed3604c7f4272ec27d45d2da943.tar.bz2
aports-14152028a43e2ed3604c7f4272ec27d45d2da943.tar.xz
testing/libtorrent: new aport
Diffstat (limited to 'testing/libtorrent/APKBUILD')
-rw-r--r--testing/libtorrent/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/libtorrent/APKBUILD b/testing/libtorrent/APKBUILD
new file mode 100644
index 000000000..06865bc7e
--- /dev/null
+++ b/testing/libtorrent/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=libtorrent
+pkgver=0.12.9
+pkgrel=1
+pkgdesc='BitTorrent library written in C++'
+url='http://libtorrent.rakshasa.no/'
+arch='all'
+license='GPL'
+makedepends='libsigc++-dev openssl-dev'
+subpackages="$pkgname-dev"
+options='libtool'
+source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-debug \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="b128bbd324f03eb42ef5060080f87548 libtorrent-0.12.9.tar.gz"