summaryrefslogtreecommitdiffstats
path: root/testing/libzip
diff options
context:
space:
mode:
authorLinux User <se@alpine-desktop.my.domain>2014-10-16 19:52:25 +0400
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-17 13:52:16 +0000
commit9085b73f09d41af164193a3e0b5e22fcce80d503 (patch)
tree5d2e5fa503bf2540ddeed992a4aba407ffa24649 /testing/libzip
parent276617c77708f50d68ba9b4c87a866399ddd7250 (diff)
downloadaports-9085b73f09d41af164193a3e0b5e22fcce80d503.tar.bz2
aports-9085b73f09d41af164193a3e0b5e22fcce80d503.tar.xz
Added KDE core packages
Diffstat (limited to 'testing/libzip')
-rw-r--r--testing/libzip/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/libzip/APKBUILD b/testing/libzip/APKBUILD
new file mode 100644
index 000000000..41d416be9
--- /dev/null
+++ b/testing/libzip/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: k0r10n <k0r10n.dev@gmail.com>
+# Maintainer:
+pkgname=libzip
+pkgver=0.11.2
+pkgrel=0
+pkgdesc="A C library for reading, creating, and modifying zip archives"
+url="http://www.nih.at/libzip/index.html"
+arch="all"
+license="BSD"
+depends=
+depends_dev="zlib-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.nih.at/libzip/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure -prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install install-man || return 1
+ mv "$pkgdir"/usr/lib/libzip/include/zipconf.h "$pkgdir"/usr/include/ || return 1
+ find "$pkgdir" -name *.la -delete
+}
+
+md5sums="c5437df15e4825d40cdc3ec8b9b7516c libzip-0.11.2.tar.gz"
+sha256sums="83db1fb43a961ff7d1d1b50e1c6bea09c67e6af867686d1fc92ecb7dc6cf98d5 libzip-0.11.2.tar.gz"
+sha512sums="51d011b389baf23f019428104c7c20dc42f2636c7f845abe7efb78a93b2fa6645fa9586351d9abd7bea1ab010a5a3b85086592033b2db362988cf6a24b72f562 libzip-0.11.2.tar.gz"