summaryrefslogtreecommitdiffstats
path: root/testing/lua-lmd5
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-14 07:51:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-14 07:51:07 +0000
commit1c0e3d879d6d4626b23e676450d72cf1e0c5bec9 (patch)
tree3b283a3aa12836bd796776182819bdaa0ee47b59 /testing/lua-lmd5
parent7c47137785b12d37b4c91a84d78d83dc18ce44f7 (diff)
downloadaports-1c0e3d879d6d4626b23e676450d72cf1e0c5bec9.tar.bz2
aports-1c0e3d879d6d4626b23e676450d72cf1e0c5bec9.tar.xz
testing/lua-lmd5: new aport
A message digest library for Lua based on OpenSSL http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/#lmd5
Diffstat (limited to 'testing/lua-lmd5')
-rw-r--r--testing/lua-lmd5/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/lua-lmd5/APKBUILD b/testing/lua-lmd5/APKBUILD
new file mode 100644
index 000000000..269f66192
--- /dev/null
+++ b/testing/lua-lmd5/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-lmd5
+pkgver=5.1.2011.03.24
+pkgrel=0
+pkgdesc="A message digest library for Lua based on OpenSSL"
+url="http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/#lmd5"
+arch="all"
+license="Public Domain"
+depends=
+makedepends="lua-dev openssl-dev"
+install=
+subpackages="$pkgname-sha"
+
+# seems like they just update the upstream source package. Version is found in
+# luuid.c
+# For date and checksum see:
+# http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/release.txt
+
+source="http://dev.alpinelinux.org/archive/lmd5/lmd5-$pkgver.tar.gz"
+#source="http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/5.1/lmd5.tar.gz"
+
+
+_builddir="$srcdir"/md5
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ make digests LUABIN=/usr/bin || return 1
+}
+
+package() {
+ cd "$_builddir"
+ local cmod=$(pkg-config --variable INSTALL_CMOD lua)
+ mkdir -p "$pkgdir"/$cmod
+ cp -a *.so "$pkgdir"/$cmod/
+}
+
+sha() {
+ local cmod=$(pkg-config --variable INSTALL_CMOD lua)
+ mkdir -p "$subpkgdir"/$cmod
+ mv "$pkgdir"/$cmod/sha*.so "$subpkgdir"/$cmod/
+}
+
+md5sums="bc336a560b7b6513982c17eec9692bd6 lmd5-5.1.2011.03.24.tar.gz"