summaryrefslogtreecommitdiffstats
path: root/testing/mac-robber
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-28 10:15:16 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-28 10:15:16 +0100
commit29c87cf21981a9dca875975b059a6d8112314d79 (patch)
treef738795b10723f2267efb5ab4674e44a88bacfb7 /testing/mac-robber
parentef774241996d2af428753fe4c67780f2cb44f20a (diff)
downloadaports-29c87cf21981a9dca875975b059a6d8112314d79.tar.bz2
aports-29c87cf21981a9dca875975b059a6d8112314d79.tar.xz
testing/mac-robber: fix build on musl
Diffstat (limited to 'testing/mac-robber')
-rw-r--r--testing/mac-robber/APKBUILD21
-rw-r--r--testing/mac-robber/include-paramh.patch10
2 files changed, 29 insertions, 2 deletions
diff --git a/testing/mac-robber/APKBUILD b/testing/mac-robber/APKBUILD
index 609c44f6f..b8e9c864d 100644
--- a/testing/mac-robber/APKBUILD
+++ b/testing/mac-robber/APKBUILD
@@ -12,9 +12,21 @@ depends_dev=""
makedepends=""
install=""
subpackages=""
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ include-paramh.patch"
+
_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
make || return 1
@@ -25,4 +37,9 @@ package() {
install -Dpm 0755 $pkgname "$pkgdir"/usr/bin/$pkgname || return 1
}
-md5sums="6d6d99aa882a46b2bc5231d195fdb595 mac-robber-1.02.tar.gz"
+md5sums="6d6d99aa882a46b2bc5231d195fdb595 mac-robber-1.02.tar.gz
+c2b45c05cd35ef2fa59b13124fe908fa include-paramh.patch"
+sha256sums="5895d332ec8d87e15f21441c61545b7f68830a2ee2c967d381773bd08504806d mac-robber-1.02.tar.gz
+f69e14c2e0f7431d16b711b719a5112ab3797520110fcf61b1c8fa1c53816bb1 include-paramh.patch"
+sha512sums="5330f766eb08aa766ca3f430684e0a40ecf29b7230a582c30a36bbaaa481d52c2a8519fa04e82762f09259ada9e77466c1430aebdff22615a511d519916d54a7 mac-robber-1.02.tar.gz
+4fc0ac48132d2dfbf150fb297d6a740d867c8308215970ac9bce433961cac3d2e32ca57060e4a5f948598f832cdafe931583993df27e9fd4d24139977311cf20 include-paramh.patch"
diff --git a/testing/mac-robber/include-paramh.patch b/testing/mac-robber/include-paramh.patch
new file mode 100644
index 000000000..1bf20fda5
--- /dev/null
+++ b/testing/mac-robber/include-paramh.patch
@@ -0,0 +1,10 @@
+--- a/mac-robber.c.orig
++++ b/mac-robber.c
+@@ -44,6 +44,7 @@
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <sys/param.h>
+ #include <dirent.h>
+ #include <stdio.h>
+ #include <stdlib.h>